程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> Counting Sheep

Counting Sheep

編輯:C++入門知識

A - Counting Sheep
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit StatusDescription

A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I'd gone to bed. As always when my grandmother suggests things, I decided to try it out. The only problem was, there were no sheep around to be counted when I went to bed.

 


Creative as I am, that wasn't going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps A and C are in the same flock.


Now, I've got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I've decided I need another computer program that does the counting for me. Then I'll be able to just start both these programs before I go to bed, and I'll sleep tight until the morning without any disturbances. I need you to write this program for me.
 
Input

The first line of input contains a single number T, the number of test cases to follow.

Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.
 
Output

For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.

Notes and Constraints
0 < T <= 100
0 < H,W <= 100

 
Sample Input

2
4 4
#.#.
.#.#
#.##
.#.#
3 5
###.#
..#..
#.###
Sample Output

6
3就是問有多少塊連在一起直接上代碼


#include <iostream>
#include <stdio.h>
using namespace std;
int map[105][105],dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}},n,m;
bool fun(int i,int j)
{
    if(i>=0&&j>=0&&i<n&&j<m)
        return true;
    return false;
}
int dfs(int i,int j)
{

    map[i][j]=0;
    for(int ii=0;ii<4;ii++)
    {
        int x=i+dir[ii][0];
        int y=j+dir[ii][1];
         if(fun(x,y)&&map[x][y])
            dfs(x,y);
    }


   return 1;
}
int main()
{
    int t,i,j,sum;
    char str[100],c;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        getchar();
        for(i=0;i<n;i++)
        {


            for(j=0;j<m;j++)
            {
                if((c=getchar())=='#')
                {
                    map[i][j]=1;
                }
                else if(c=='.')
                {
                    map[i][j]=0;
                }

            }
            gets(str);
        }
        sum=0;
        for(i=0;i<n;i++)
            for(j=0;j<m;j++)
            {

                if(map[i][j])
                sum+=dfs(i,j);

            }
        printf("%d\n",sum);

    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved