程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu 2602 Bone Collector

hdu 2602 Bone Collector

編輯:C++入門知識

Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 


 
Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 
Output

One integer per line representing the maximum of the total value (this number will be less than 231).
 
Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output

14就是01背包真接上代碼
 

#include<stdio.h>  
 int c[3500],w[3500],f[13000];
  int main()  {      int i,j,k,n,v,m,t; 
    scanf("%d",&t);  
   while(t--) 
    {          scanf("%d%d",&n,&m);  
       for(i=0;i<=m;i++)              f[i]=0; 
        for(i=0;i<n;i++)              scanf("%d",w+i);  
       for(i=0;i<n;i++)              scanf("%d",c+i);   
      for (i = 0; i < n; ++i)          {              for (v = m;
 v >= c[i]; --v) //注意這裡的V是從大到小c[i]可優化為bound,bound = max {V - sum c[i,...n],c[i]} 
            {                  f[v] = (f[v] > f[v - c[i]] + w[i]?f[v] : f[v - c[i]] + w[i]); 
            }          }          printf("%d\n",f[m]); 
    }      return 0;
 }  #include<stdio.h>

int c[3500],w[3500],f[13000];
int main()
{
 int i,j,k,n,v,m,t;
 scanf("%d",&t);
 while(t--)
 {
  scanf("%d%d",&n,&m);
  for(i=0;i<=m;i++)
   f[i]=0;
  for(i=0;i<n;i++)
   scanf("%d",w+i);
  for(i=0;i<n;i++)
   scanf("%d",c+i);
  for (i = 0; i < n; ++i)
  {
   for (v = m; v >= c[i]; --v) //注意這裡的V是從大到小c[i]可優化為bound,bound = max {V - sum c[i,...n],c[i]}
   {
    f[v] = (f[v] > f[v - c[i]] + w[i]?f[v] : f[v - c[i]] + w[i]);
   }
  }
  printf("%d\n",f[m]);
 }
 return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved