程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> uva-442 Matrix Chain Multiplication

uva-442 Matrix Chain Multiplication

編輯:C++入門知識

 Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.


For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).

The first one takes 15000 elementary multiplications, but the second one only 3500.


Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.


Input Specification
Input consists of two parts: a list of matrices and a list of expressions.

The first line of the input file contains one integer n (  ), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.


The second part of the input file strictly adheres to the following syntax (given in EBNF):


SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"
Output Specification
For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.


Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))
Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125題目意思:給出字符代表矩陣的定義,計算表達示中矩陣相乘的總次數;解題思路:定義一個stack<node>st,用node(-1,-1)代表左括號,從左到右掃描,如果是左括號則st.push(node(-1,01));如果是字母則push字母對應的矩陣;如果是右括號則把矩陣pop出來計算,一直到左括號;


#include <iostream>
#include<deque>
#include<algorithm>
#include<cstdio>
#include<stack>
#include<string>
#include<vector>
#include<map>
using namespace std;

//bool check (vector<string>&v,map<string,int>&m)
//{
//    for(unsigned int i=1;i<v.size();i++)
//        if(m[v[i]]-m[v[i-1]]!=1)
//            return false;
//    return true;
//}
//int main()
//{
//    int cas;
//    cin>>cas;
//    getchar();
//    while(cas--)
//    {
//        int n;
//        cin>>n;
//        getchar();
//        vector<string>v;
//        string s;
//        map<string ,int>m;
//        for(int i=0; i<n; i++)
//        {
//            getline(cin,s);
//            v.push_back(s);
//        }
//        for(int i=0; i<n; i++)
//        {
//            getline(cin,s);
//            m[s]=i;
//        }
//        for(int q=0; q<n-1;)
//        {
//            //if(check(v,m))break;
//            bool flag=1;
//            for(int i=q+1; i<n; i++)
//            {
//                if(m[v[q]]-m[v[i]]==1)
//                {
//                    cout<<v[i]<<endl;
//                    string t=v[i];
//                    for(int j=i; j>0; j--)
//                        v[j]=v[j-1];
//                    v[0]=t;
//                    flag=0;
//                    q=0;
//                    break;
//                }
//            }
//            if(flag)q++;
//        }
//        cout<<endl;
//    }
//    return 0;
//}

struct node
{
    int x,y;
    node(int a=0,int b=0):x(a),y(b) {}
};
int main()
{
    int n;
    cin>>n;
    char c;
    int x,y;
    node arr[200];
    for(int i=0; i<n; i++)
        cin>>c>>x>>y,arr[c]=node(x,y);
    string exp;
    while(cin>>exp)
    {
        stack<node>st;
        int sum=0;
        bool flag=0;
        for(int i=0; i<exp.size(); i++)
        {
            if(exp[i]!=')')
            {
                if(exp[i]=='(')
                    st.push(node(-1,-1));
                else
                    st.push(arr[exp[i]]);
            }
            else if(!st.empty())
            {
                node matrix1=st.top();
                    st.pop();
                while(st.top().x!=-1)
                {
                    node matrix2=st.top();
                    st.pop();
                    if(matrix1.x!=matrix2.y)
                    {
                        flag=1;
                        cout<<"error"<<endl;
                        i=exp.size();
                        break;
                    }
                    sum+=matrix2.x*matrix2.y*matrix1.y;
                    matrix1=node(matrix2.x,matrix1.y);
                }
                st.pop();
                st.push(matrix1);
            }
            else
            {
            cout<<"error"<<endl;
            flag=1;
            }
        }
        while(st.size()!=1&&!flag)
        {
            node matrix2=st.top();
            st.pop();
            node matrix1=st.top();
            st.pop();
            if(matrix1.y!=matrix2.x)
            {
                cout<<"error"<<endl;
                break;
            }
            st.push(node(matrix1.x,matrix2.y));
            sum+=matrix1.x*matrix1.y*matrix2.y;
        }
        if(!flag)
        cout<<sum<<endl;
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved