程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> uva-673 Parentheses Balance

uva-673 Parentheses Balance

編輯:C++入門知識

Description

 
 

You are given a string consisting of parentheses () and []. A string of this type is said to be correct:

(a)
if it is the empty string
(b)
if A and B are correct, AB is correct,
(c)
if A is correct, (A) and [A] is correct.
Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.

 

Input
The file contains a positive integer n and a sequence of n strings of parentheses () and [], one string a line.

 

Output
A sequence of Yes or No on the output file.

 

Sample Input
 

3
([])
(([()])))
([()[]()])()
 

Sample Output
Yes
No
Yes
 這個題的意思是看一個表達示的括號是不是平衡的,空表達示也是平衡的,平衡就輸出YES,否則輸出NO。

解題思路:

1.如果表達示為空,輸出YES。

2.利用一個棧,表達示從左到右掃描,遇到左括號入棧,右括號出棧,如果最後線空輸出YES,否則輸出NO。

 

include <iostream>
#include<deque>
#include<algorithm>
#include<cstdio>
#include<stack>
#include<string>
using namespace std;
char f(char c)
{
    if(c==')')return '(';
    if(c==']')return '[';
    return 0;
}
bool judge(const string& s)
{
    stack<char>st;
    st.push('0');
    for(int i=0;i<s.size();i++)
    {
        if(st.top()!=f(s[i]))
        st.push(s[i]);
        else st.pop();
    }
    return st.size()==1;
}


int main()
{
    int n;
    cin>>n;
    string s;
    getchar();
    while(n--)
    {
        getline(cin,s);
        if(s.size()==0||judge(s))cout<<"Yes"<<endl;
        else cout<<"No"<<endl;
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved