程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> UVA 489 - Hangman Judge

UVA 489 - Hangman Judge

編輯:C++入門知識

Hangman Judge
In ``Hangman Judge,'' you are to write a program that judges a series of Hangman games. For each game, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic game of hangman, and are given as follows:

The contestant tries to solve to puzzle by guessing one letter at a time.
Every time a guess is correct, all the characters in the word that match the guess will be ``turned over.'' For example, if your guess is ``o'' and the word is ``book'', then both ``o''s in the solution will be counted as ``solved.''
Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, which needs 7 strokes to complete. Each unique wrong guess only counts against the contestant once.

   ______  
   |  |    
   |  O    
   | /|\   
   |  |    
   | / \   
 __|_      
 |   |______
 |_________|If the drawing of the hangman is completed before the contestant has successfully guessed all the characters of the word, the contestant loses.
If the contestant has guessed all the characters of the word before the drawing is complete, the contestant wins the game.
If the contestant does not guess enough letters to either win or lose, the contestant chickens out.
Your task as the ``Hangman Judge'' is to determine, for each game, whether the contestant wins, loses, or fails to finish a game.


Input
Your program will be given a series of inputs regarding the status of a game. All input will be in lower case. The first line of each section will contain a number to indicate which round of the game is being played; the next line will be the solution to the puzzle; the last line is a sequence of the guesses made by the contestant. A round number of -1 would indicate the end of all games (and input).


Output
The output of your program is to indicate which round of the game the contestant is currently playing as well as the result of the game. There are three possible results:


You win.
You lose.
You chickened out.
Sample Input

1
cheese
chese
2
cheese
abcdefg
3
cheese
abcdefgij
-1
Sample Output

Round 1
You win.
Round 2
You chickened out.
Round 3
You lose.題意:每組數據先輸入一個n,代表第幾組數據,第二行是一個要猜的字符串,第三行是你猜的字符串,如果猜對了一個字母,就說你把第一個字符串中所有與你猜對的相同的字母都猜對了。如果第一個字符串中的字母全被猜對了,輸出you win.如果猜錯的次數達到7次,輸出You  lose. 否則輸出You chickened  out.

#include<stdio.h>
#include<string.h>
int stroke;
int s[105]; /*記錄第一行字符串中的字母是否猜過*/
int JudgeCorrect(char *a,char *b)
{
	int cnt,i,j,flag;
    stroke=0; /*猜錯的次數*/
	cnt=0; /*猜對的次數*/
	memset(s,0,sizeof(s));
	for(i=0;i<strlen(b);i++)
	{
		flag=0;
		if(stroke==7) 
			break;
		for(j=0;j<strlen(a);j++)
		{
			if(b[i]==a[j]&&!s[j])
			{
				s[j]=1;
				cnt++;
				flag=1;
			}
		}
		if(!flag)
			stroke++;
	}
	return cnt;
}
int main()
{
	int i,j,cases,count,flag;
	char guess[105],answer[105];
	while(~scanf("%d",&cases)&&cases!=-1)
	{
		getchar();
		gets(answer);
		gets(guess);
		count=JudgeCorrect(answer,guess);
		printf("Round %d\n",cases);
		if(count==strlen(answer))  /*全猜對了*/
			printf("You win.\n");
		else if(stroke==7) /*猜錯的次數達到7次*/
			printf("You lose.\n");
		else
			printf("You chickened out.\n");
	}
	return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved