程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu 1536 SG函數模板題 千萬注意游戲的組合用SG函數值異或 是SG函數的值啊

hdu 1536 SG函數模板題 千萬注意游戲的組合用SG函數值異或 是SG函數的值啊

編輯:C++入門知識

S-Nim Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 3077    Accepted Submission(s): 1361       Problem Description Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:       The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.     The players take turns chosing a heap and removing a positive number of beads from it.     The first player not able to make a move, loses.     Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:       Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).     If the xor-sum is 0, too bad, you will lose.     Otherwise, move such that the xor-sum becomes 0. This is always possible.     It is quite easy to convince oneself that this works. Consider these facts:     The player that takes the last bead wins.     After the winning player's last move the xor-sum will be 0.     The xor-sum will change after every move.     Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.   Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?   your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.       Input Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.       Output For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'. Print a newline after each test case.         Sample Input 2 2 5 3 2 5 12 3 2 4 7 4 2 3 7 12 5 1 2 3 4 5 3 2 5 12 3 2 4 7 4 2 3 7 12 0      Sample Output LWW WWL      Source Norgesmesterskapet 2004       Recommend LL   題意: 首先輸入K 表示一個集合的大小  之後輸入集合 表示對於這對石子只能去這個集合中的元素的個數  之後輸入 一個m 表示接下來對於這個集合要進行m次詢問   之後m行 每行輸入一個n 表示有n個堆  每堆有n1個石子  問這一行所表示的狀態是贏還是輸 如果贏輸入W否則L   思路: 對於n堆石子 可以分成n個游戲 之後把n個游戲合起來就好了  

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
//注意 S數組要按從小到大排序 SG函數要初始化為-1 對於每個集合只需初始化1邊
//不需要每求一個數的SG就初始化一邊
int SG[10100],n,m,s[102],k;//k是集合s的大小 S[i]是定義的特殊取法規則的數組
int dfs(int x)//求SG[x]模板
{
    if(SG[x]!=-1) return SG[x];
    bool vis[110];
    memset(vis,0,sizeof(vis));

    for(int i=0;i<k;i++)
    {
        if(x>=s[i])
        {
           dfs(x-s[i]);
           vis[SG[x-s[i]]]=1;
         }
    }
    int e;
    for(int i=0;;i++)
      if(!vis[i])
      {
        e=i;
        break;
      }
    return SG[x]=e;
}
int main()
{
    int cas,i;
    while(scanf("%d",&k)!=EOF)
    {
        if(!k) break;
        memset(SG,-1,sizeof(SG));
        for(i=0;i<k;i++) scanf("%d",&s[i]);
        sort(s,s+k);
        scanf("%d",&cas);
        while(cas--)
        {
            int t,sum=0;
            scanf("%d",&t);
            while(t--)
            {
                int num;
                scanf("%d",&num);
                sum^=dfs(num);
               // printf("SG[%d]=%d\n",num,SG[num]);
            }
            if(sum==0) printf("L");
            else printf("W");
        }
        printf("\n");
    }
    return 0;
}
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int K=101;
const int H=10001;//H是我們要打表打到的最大值
int k,m,l,h,s[K],sg[H],mex[K];///k是集合元素的個數 s[]是集合  mex大小大約和集合大小差不多
///注意s的排序
void sprague_grundy()
{
    int i,j;
    sg[0]=0;
    for (i=1;i<H;i++){
        memset(mex,0,sizeof(mex));
        j=1;
        while (j<=k && i>=s[j]){ 
            mex[sg[i-s[j]]]=1;
            j++;
        }
        j=0;
        while (mex[j]) j++;
        sg[i]=j;
    }
}

int main(){
    int tmp,i,j;

    scanf("%d",&k);
    while (k!=0){
        for (i=1;i<=k;i++)
            scanf("%d",&s[i]);
        sort(s+1,s+k+1);            //這個不能少
        sprague_grundy();
        scanf("%d",&m);
        for (i=0;i<m;i++){
            scanf("%d",&l);
            tmp=0;
            for (j=0;j<l;j++){
                scanf("%d",&h);
                tmp=tmp^sg[h];
            }
            if (tmp)
                putchar('W');
            else
                putchar('L');
        }
        putchar('\n');
        scanf("%d",&k);
    }
    return 0;}

 


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved