程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj3278Catch That Cow(BFS)

poj3278Catch That Cow(BFS)

編輯:C++入門知識

Catch That Cow Time Limit: 2000MS   Memory Limit: 65536K  Total Submissions: 37094   Accepted: 11466    Description   Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.   * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute.   If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?   Input   Line 1: Two space-separated integers: N and K Output   Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow. Sample Input   5 17Sample Output   4Hint   The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.     剛做的時候發生了很多奇異YY, 搞的我不知道重寫了多少遍。。     從當前位置local,向local+1, local-1, local*2這三個方向擴展。 code:

#include <queue>   
#include <cstdio>   
#include<cstring>   
#define N 100001   
using namespace std;  
int n, k, ans;  
bool vis[N];  
struct node {  
    int local, time;  
};  
void bfs() {  
    int t, i;  
    node now, tmp;  
    queue<node> q;  
    now.local = n;  
    now.time = 0;  
    q.push(now);  
    memset(vis,false,sizeof(vis));  
    vis[now.local] = true;  
    while(!q.empty()) {  
        now = q.front();  
        q.pop();  
        for(i=0; i<3; i++) {  
            if(0==i) t = now.local-1;  
            else if(1==i) t = now.local+1;  
            else if(2==i) t = now.local*2;  
            if(t<0||t>N||vis[t]) continue;  
            if(t==k) {  
                ans = now.time+1;  
                return;  
            }  
            vis[t] = true;  
            tmp.local = t;  
            tmp.time = now.time+1;  
            q.push(tmp);  
        }  
    }  
}  
  
int main() {  
    while(~scanf("%d%d",&n,&k)) {  
        if(n>=k) printf("%d\n",n-k);  
        else {  
            bfs();  
            printf("%d\n",ans);  
        }  
    }  
}  

 


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved