程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu1397(素數組和成偶數的個數 用 標記法)

hdu1397(素數組和成偶數的個數 用 標記法)

編輯:C++入門知識

Problem Description Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.  This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.   A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.       Input An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.       Output Each output line should contain an integer number. No other characters should appear in the output.       Sample Input 6 10 12 0   Sample Output 1 2

#include<iostream>  
 #include<cmath>  
 using namespace std; 
 int prime[800000]; 
 int isprime(int a)//判斷是否是素數   {      int i;   
   for (i=2;i<=sqrt(a*1.0)+0.5;i++)   
   if(a%i==0)      return 0;    
  return 1;  
}  void prime_b()//打素數表   {      int i; 
     for(i=2;
i<=32768;i++)  
    if(isprime(i))//i是素數記為1       prime[i]=1; 
     else  //不是記為0       prime[i]=0;
  }  int main()  {      int n,p,k;    
        prime_b();       
     while(cin>>n&&n)      {          k=0;      
    if(prime[n-2])//和2組和的數           k++;     
     for(p=3;p<=n/2;
p+=2)          if(prime[p]&&prime[n-p])          k++;    
      cout<<k<<endl;   
   }  }  

 


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved