程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU 2041 超級樓梯

HDU 2041 超級樓梯

編輯:C++入門知識

Problem Description
有一樓梯共M級,剛開始時你在第一級,若每次只能跨上一級或二級,要走上第M級,共有多少種走法?
 


Input
輸入數據首先包含一個整數N,表示測試實例的個數,然後是N行數據,每行包含一個整數M(1<=M<=40),表示樓梯的級數。
 


Output
對於每個測試實例,請輸出不同走法的數量
 


Sample Input
2
2
3


Sample Output
1
2

 

 

import java.io.BufferedInputStream;
import java.util.*;
public class Main {
	public static void main(String[] args) {
		Scanner sc=new Scanner(new BufferedInputStream(System.in));
		int k,m,n;
		k=sc.nextInt();
		for(int i=0;i<k;i++)
		{
			m=sc.nextInt();
			n=fun(m);
			System.out.println(n);
		}
	}
	public static int fun(int m)
	{
		int sum=0;
		int a[]=new int[m];
		for(int i=2,j=0;i<=m;i++,j++)
		{
			if(i==2)
				{
					a[j]=1;
					sum=a[j];
				}
			else if(i==3){
				a[j]=2;
				sum=a[j];
			}
			else {
				a[j]=a[j-1]+a[j-2];
				sum=a[j];
			}
		}
		return sum;
	}
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved