程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu 2196 computer (樹形dp)

hdu 2196 computer (樹形dp)

編輯:C++入門知識

分類: acm 動態規劃 2013-07-21 15:53 93人閱讀 評論(0) 收藏 舉報
Computer
Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1885    Accepted Submission(s): 934


Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.

 


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
5
1 1
2 1
3 1
1 1

Sample Output
3
2
3
4
4

Author
scnu
 

Recommend
lcy
 


解題思路:
題意是求樹中每個點到所有葉子節點的距離的最大值是多少。
由於對於一個節點來說,可能得到的距離最大的值的路徑來自他的子樹,或者從他的父節點過來,所以用兩次DFS。
第一次DFS求出所有節點在他的子樹范圍內到葉子節點距離的最大值和第二大的值,第二次DFS更新從父節點過來的情況就可以了。
因為如果只存最大值的話,判斷一個點的從父節點過來的最大值,那麼如果他的父節點存的最大值正好是從該點過來的,那麼就失去了從父節點過來的狀態,所以要記錄最大的兩個值。

 

#include <cstdio>
#include <algorithm>
using namespace std;
const long M=21000;
long dp[M][2],id[M][2],n;
long head[M],Next[M],to[M],val[M],cnt;
void init_edge(){
	for (long i=1;i<=n;++i) head[i]=-1;
	cnt=0;
}
void add_edge(long u,long v,long c){
	Next[++cnt]=head[u]; head[u]=cnt; to[cnt]=v;
	val[cnt]=c;
}

void Swap(long x){
	if (dp[x][1]>=dp[x][0]){
		swap(dp[x][1],dp[x][0]);
		swap(id[x][1],id[x][0]);
	}
}

void dfs1(long u,long f){
	dp[u][0]=0;  dp[u][1]=0;
	for (long i=head[u];i!=-1;i=Next[i]){
		long v=to[i];
		if (v==f) continue;
		dfs1(v,u);
		if (dp[v][0]+val[i]>dp[u][1]){
			dp[u][1]=dp[v][0]+val[i];
			id[u][1]=v;
			Swap(u);
		}
	}
}

void dfs2(long u,long f){
	for (long i=head[u];i!=-1;i=Next[i]){
		long v=to[i];
		if (v==f) continue;
		if (v==id[u][0]){
			if (dp[u][1]+val[i]>dp[v][1]){
				dp[v][1]=dp[u][1]+val[i];
				id[v][1]=u;
				Swap(v);
			}
		}
		else{
			if (dp[u][0]+val[i]>dp[v][1]){
				dp[v][1]=dp[u][0]+val[i];
				id[v][1]=u;
				Swap(v);
			}
		}
		dfs2(v,u);
	}
}

int main(){
	while (~scanf("%d",&n)){
		init_edge();
		for (long i=2;i<=n;++i){
			long u,c;
			scanf("%d%d",&u,&c);
			add_edge(u,i,c); add_edge(i,u,c);
		}
		dfs1(1,-1);

		dfs2(1,-1);
		for (long i=1;i<=n;++i)
			printf("%d\n",dp[i][0]);
	}
	return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved