程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU 2035 人見人愛A^B

HDU 2035 人見人愛A^B

編輯:C++入門知識

Problem Description
求A^B的最後三位數表示的整數。
說明:A^B的含義是“A的B次方”


 

Input
輸入數據包含多個測試實例,每個實例占一行,由兩個正整數A和B組成(1<=A,B<=10000),如果A=0, B=0,則表示輸入數據的結束,不做處理。

 

Output
對於每個測試實例,請輸出A^B的最後三位表示的整數,每個輸出占一行。


 

Sample Input
2 3
12 6
6789 10000
0 0
 

Sample Output
8
984
1
 

 

import java.io.BufferedInputStream;
import java.math.BigInteger;
import java.util.*;
public class Main {
	public static void main(String[] args) {
		Scanner sc=new Scanner(new BufferedInputStream(System.in));
		while(sc.hasNextInt()){
			BigInteger a=BigInteger.valueOf(sc.nextInt());
			BigInteger b=BigInteger.valueOf(sc.nextInt());
			if(a.intValue()==0&&b.intValue()==0) System.exit(0);
			BigInteger sum=a.pow(b.intValue());
			String s=String.valueOf(sum);
			if(s.length()>4){
				System.out.println(Integer.parseInt(s.substring(s.length()-3,s.length())));
			}
			else System.out.println(sum);
		}
	}

}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved