程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu 1240 Asteroids! (三維bfs)

hdu 1240 Asteroids! (三維bfs)

編輯:C++入門知識

Asteroids!
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2599    Accepted Submission(s): 1745

 

Problem Description
You're in space.
You want to get home.
There are asteroids.
You don't want to hit them.

 

Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 5 components:

Start line - A single line, "START N", where 1 <= N <= 10.

Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:

'O' - (the letter "oh") Empty space

'X' - (upper-case) Asteroid present

Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.

Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.

End line - A single line, "END"

The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

The first coordinate in a set indicates the column. Left column = 0.

The second coordinate in a set indicates the row. Top row = 0.

The third coordinate in a set indicates the slice. First slice = 0.

Both the Starting Position and the Target Position will be in empty space.

 


Output
For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.

 


Sample Input
START 1
O
0 0 0
0 0 0
END
START 3
XXX
XXX
XXX
OOO
OOO
OOO
XXX
XXX
XXX
0 0 1
2 2 1
END
START 5
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
XXXXX
XXXXX
XXXXX
XXXXX
XXXXX
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
0 0 0
4 4 4
END

Sample Output
1 0
3 4
NO ROUTE

Source
South Central USA 2001


Recommend
zf

題意:三維迷宮。從起點到終點的最少步數。如果不能走到終點,輸出“NO ROUTE”。

代碼:

 

#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;

struct node
{
    int x,y,z;
    int steps;
}start,endd,next;
int dx[6]={0,0,0,0,1,-1};    //上下左右前後
int dy[6]={0,0,-1,1,0,0};
int dz[6]={1,-1,0,0,0,0};
char maps[15][15][15];
int n,res;

bool cango(node &a)
{
    if(a.x>=0&&a.x<n&&a.y>=0&&a.y<n&&a.z>=0&&a.z<n)
        return true;
    else return false;
}

int bfs()
{
    if(start.x==endd.x&&start.y==endd.y&&start.z==endd.z)
        return res;
    node cur;
    queue<node> q;
    while(!q.empty())
        q.pop();
    q.push(start);
    maps[start.x][start.y][start.z]='X';
    while(!q.empty())
    {
        cur=q.front();
        q.pop();
        for(int i=0;i<6;i++)
        {
            next.x=cur.x+dx[i];
            next.y=cur.y+dy[i];
            next.z=cur.z+dz[i];
            if(next.x==endd.x&&next.y==endd.y&&next.z==endd.z) //
                return cur.steps+1;                             //
            if(maps[next.x][next.y][next.z]=='O'&&cango(next))
            {
				//printf("test: %d %d %d\n",next.x,next.y,next.z);
                next.steps=cur.steps+1;
                maps[next.x][next.y][next.z]='X';
                q.push(next);
            }
        }
    }
    return -1;
}

int main()
{
    int i,j;
    char st[6],ed[6];
    while(scanf("%s%d",&st,&n)!=EOF)
    {
        getchar();
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
                scanf("%s",maps[i][j]);
            getchar();
        }
        scanf("%d%d%d",&start.x,&start.y,&start.z);
        scanf("%d%d%d",&endd.x,&endd.y,&endd.z);
        getchar();
        gets(ed);
        res=0;
        start.steps=0;
        res=bfs();
        if(res>=0) printf("%d %d\n",n,res);
        else printf("NO ROUTE\n");
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved