程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU 2043 密碼

HDU 2043 密碼

編輯:C++入門知識

密碼
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23180 Accepted Submission(s): 9260

 


Problem Description

網上流傳一句話:"常在網上飄啊,哪能不挨刀啊~"。其實要想能安安心心地上網其實也不難,學點安全知識就可以。

首先,我們就要設置一個安全的密碼。那什麼樣的密碼才叫安全的呢?一般來說一個比較安全的密碼至少應該滿足下面兩個條件:

(1).密碼長度大於等於8,且不要超過16。
(2).密碼中的字符應該來自下面“字符類別”中四組中的至少三組。

這四個字符類別分別為:
1.大寫字母:A,B,C...Z;
2.小寫字母:a,b,c...z;
3.數字:0,1,2...9;
4.特殊符號:~,!,@,#,$,%,^;

給你一個密碼,你的任務就是判斷它是不是一個安全的密碼。

 

Input
輸入數據第一行包含一個數M,接下有M行,每行一個密碼(長度最大可能為50),密碼僅包括上面的四類字符。


Output
對於每個測試實例,判斷這個密碼是不是一個安全的密碼,是的話輸出YES,否則輸出NO。


Sample Input
3
a1b2c3d4
Linle@ACM
^~^@^@!%

Sample Output
NO
YES
NO
 

import java.io.BufferedInputStream;
import java.util.*;
import java.util.regex.Matcher;
import java.util.regex.Pattern;

public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(new BufferedInputStream(System.in));
		int n = sc.nextInt();
		sc.nextLine();
		for (int i = 0; i < n; i++) {
			String s = sc.nextLine();

			if (s.length() >= 8 && s.length() <= 16) {
				//匹配 大寫字母 A-Z任意一個字母
				Pattern p1 = Pattern.compile("[A-Z]");
				Matcher m1 = p1.matcher(s);
				//匹配小寫字母a-z任意一個字母
				Pattern p2 = Pattern.compile("[a-z]");
				Matcher m2 = p2.matcher(s);
				//匹配0-9任意一個數字
				Pattern p3 = Pattern.compile("\\d");
				Matcher m3 = p3.matcher(s);
				//匹配特殊字符
				Pattern p4 = Pattern.compile("~|!|@|#|\\$|%|\\^");
				Matcher m4 = p4.matcher(s);

				if (m1.find() && m2.find() && m3.find() && m4.find()) {
					System.out.println("YES");
				} else if (m1.find() && m2.find() && m3.find()) {
					System.out.println("YES");
				} else if (m1.find() && m2.find() && m4.find()) {
					System.out.println("YES");
				} else if (m1.find() && m3.find() && m4.find()) {
					System.out.println("YES");
				} else if (m2.find() && m3.find() && m4.find()) {
					System.out.println("YES");
				}

				else
					System.out.println("NO");
			} else
				System.out.println("NO");
		}
	}

}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved