程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU 2025 查找最大元素

HDU 2025 查找最大元素

編輯:C++入門知識

查找最大元素
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22046 Accepted Submission(s): 12094

 


Problem Description
對於輸入的每個字符串,查找其中的最大字母,在該字母後面插入字符串“(max)”。

 

Input
輸入數據包括多個測試實例,每個實例由一行長度不超過100的字符串組成,字符串僅由大小寫字母構成。

 

Output
對於每個測試實例輸出一行字符串,輸出的結果是插入字符串“(max)”後的結果,如果存在多個最大的字母,就在每一個最大字母後面都插入"(max)"。

 

Sample Input
abcdefgfedcba
xxxxx

Sample Output
abcdefg(max)fedcba
x(max)x(max)x(max)x(max)x(max)

import java.io.BufferedInputStream;
import java.util.*;

public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(new BufferedInputStream(System.in));
		while (sc.hasNextLine()) {
			String s = sc.nextLine();
			if (s.length() < 100) {
				int j = 0;
				for (int i = 0; i < s.length(); i++) {
					if (s.charAt(i) > s.charAt(j))
						j = i;
				}
				StringBuffer bu = new StringBuffer();
				for (int i = 0; i < s.length(); i++) {
					bu.append(s.charAt(i));
					if (s.charAt(i) == s.charAt(j))
						bu.append("(max)");
				}
				System.out.println(bu.toString());
			}
		}
	}

}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved