程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> POJ1742:Coins(多重背包)

POJ1742:Coins(多重背包)

編輯:C++入門知識

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.
Output

For each test case output the answer on a single line.
Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output

8
4
這道題與杭電的一道題的題意是相同的,之所以拿出來是因為杭電那道題的代碼在這裡過不了,所以貼一個新的代碼


#include <stdio.h>
#include <algorithm>
#include <string.h>

int dp[100005];
int sum[100005];
int v[105],c[105];

int main()
{
    int i,j,k,n,m;
    while(~scanf("%d%d",&n,&m),n+m)
    {
        for(i = 1;i<=n;i++)
        scanf("%d",&v[i]);
        for(i = 1;i<=n;i++)
        scanf("%d",&c[i]);
        memset(dp,0,sizeof(dp));
        dp[0] = 1;
        int ans = 0;
        for(i=1;i<=n;i++)
        {
            memset(sum,0,sizeof(sum));
            for(j = v[i];j<=m;j++)
            {
                if(!dp[j] && dp[j-v[i]] && sum[j-v[i]]<c[i])
                {
                    dp[j] = 1;
                    sum[j] = sum[j-v[i]]+1;
                    ans++;
                }
            }
        }
        printf("%d\n",ans);
    }

    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved