程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU--杭電--1358--Period--KMP--next值的應用

HDU--杭電--1358--Period--KMP--next值的應用

編輯:C++入門知識

Period
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1959    Accepted Submission(s): 961

 


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

 

 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

 

 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

 

 

Sample Input
3
aaa
12
aabaabaabaab
0

 

Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

#include <iostream>
#include <cstring>
using namespace std;
int next[1111111];
char s[1111111];
void getnext(int l)  //求next數組
{
    int i=0,j=-1;next[i]=j;
    while(i<l)
    {
        if(j==-1||s[i]==s[j])
        {
            next[++i]=++j;
            if(i%(i-next[i])==0&&i/(i-next[i])>1)  //對每次求出來的next進行判別,符合輸出就輸出
                cout<<i<<" "<<i/(i-next[i])<<endl;
        }
        else j=next[j];
    }
}
int main (void)
{
    int i,k=1,l;
    while(cin>>l&&l)
    {
        cin>>s;
        cout<<"Test case #"<<k++<<endl;
        getnext(l);
        cout<<endl;
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved