程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu 1250 Hats Fibonacci

hdu 1250 Hats Fibonacci

編輯:C++入門知識

Hat's Fibonacci
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5590    Accepted Submission(s): 1866

 


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.

 

Input
Each line will contain an integers. Process to end of file.

 

Output
For each case, output the result in a line.
 

Sample Input
100

Sample Output
4203968145672990846840663646


Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.


 

import java.math.BigInteger;
import java.util.Scanner;
public class Main{
	/*
	 * n<7040
	 */
	public static void main(String[] args) {
		Scanner input=new Scanner(System.in);
		//F f[]=new F[10000000];7040
		BigInteger f[]=new BigInteger[8];
		while(input.hasNext()){
			f[1]=BigInteger.valueOf(1);
			f[2]=BigInteger.valueOf(1);
			f[3]=BigInteger.valueOf(1);
			f[4]=BigInteger.valueOf(1);
			int n=input.nextInt();
			if(n<=4){
				System.out.println(f[n]);
			}
			else {
				for(int i=5;i<=n;i++)
				{
					f[5]=f[1].add(f[2].add(f[3].add(f[4])));
					f[1]=f[2];
					f[2]=f[3];
					f[3]=f[4];
					f[4]=f[5];
				}
				System.out.println(f[5].toString());
			}
		}
	}
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved