程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu 1312 Red and Black (簡單dfs)

hdu 1312 Red and Black (簡單dfs)

編輯:C++入門知識

Red and Black
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6453    Accepted Submission(s): 4081

 

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

 

Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output
45
59
6
13

Source
Asia 2004, Ehime (Japan), Japan Domestic


Recommend
Eddy

 

題意:紅格子和黑格子。人只能走黑格子。數人能走多少個黑格子並輸出。

代碼:

 

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;

char maps[25][25];
int r,c,sx,sy,res;
int dx[]={-1,1,0,0};
int dy[]={0,0,-1,1};

void dfs(int a,int b)
{
    for(int i=0;i<4;i++)
    {
        int xx=a+dx[i];
        int yy=b+dy[i];
        if(xx>=1&&xx<=r&&yy>=1&&yy<=c&&maps[xx][yy]=='.')
        {
            maps[xx][yy]='#';
            res++;
			dfs(xx,yy);
        }
    }
}

int main()
{
    int i,j;
	while(scanf("%d%d",&c,&r)&&r&&c)
    {	
		memset(maps,0,sizeof(maps));
		res=1;
        getchar();
        for(i=1;i<=r;i++)
        {
            for(j=1;j<=c;j++)
            {
                scanf("%c",&maps[i][j]);
                if(maps[i][j]=='@')
                {
                    sx=i;
                    sy=j;
                    maps[i][j]='#';
                }
            }
            getchar();
        }
        dfs(sx,sy);
        printf("%d\n",res);
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved