程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU 2051 Bitset

HDU 2051 Bitset

編輯:C++入門知識

Bitset
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9931 Accepted Submission(s): 7686

 


Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)


Input
For each case there is a postive number n on base ten, end of file.


Output
For each case output a number on base two.


Sample Input
1
2
3

Sample Output
1
10
11

 


 

 

import java.io.*;
import java.util.*;
public class Main {
	public static void main(String[] args) {
		Scanner sc=new Scanner(new BufferedInputStream(System.in));
		while(sc.hasNext()){
			int m=sc.nextInt();
			String s=Integer.toBinaryString(m);
			System.out.println(s);
		}
	}

}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved