程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> Strategic Game HDU

Strategic Game HDU

編輯:C++入門知識

                          Strategic Game
                                                        Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                        Total Submission(s): 3772    Accepted Submission(s): 1663

 

Problem Description
             Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree:

 \ 
 

the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:

 


Sample Input
4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)


Sample Output
1
2


Source
Southeastern Europe 2000
 
 
 
 
題意:
             一道很明了的二分匹配圖的最小點覆蓋問題;
         最小點覆蓋 == 最大匹配數;    想知道為什麼的話,可以看一下我學長的博客:鏈接地址
        題目意思就不啰嗦了,自己看吧。要注意的就是,該題是一個雙向圖,所以結果要除以2;還有就是數據太大,要用到鄰接表的使用。不懂的使用鄰接表的話自己去上網查看學習吧,或者本人博客中也有介紹鄰接表的使用。
 
 
 

#include <stdio.h> 
#include <string.h> 
#define CL(x,v);memset(x,v,sizeof(x)); 
 
const int maxn = 1500 + 10; 
int n,top,link[maxn]; 
bool used[maxn]; 
int next[maxn*maxn],head[maxn*maxn],num[maxn*maxn]; 
 
int Find(int u) 
{ 
     for(int i = head[u];i != -1;i = next[i]) 
     { 
         int v = num[i]; 
         if(!used[v]) 
         { 
             used[v] = u; 
             if(link[v] == -1||Find(link[v])) 
             { 
                 link[v] = u; 
                 return 1; 
             } 
         } 
     } 
     return 0; 
} 
 
int KM() 
{ 
    int res = 0; 
    CL(link,-1); 
    for(int u = 0;u < n;u++) 
    { 
        CL(used,0); 
        res += Find(u); 
    } 
    return res; 
} 
 
int main() 
{ 
    int m,i,j,index,vex; 
    while(~scanf("%d",&n)) 
    { 
        top = 0; 
        CL(head,-1); 
        for(i = 0;i < n;i++) 
        { 
            scanf("%d:(%d)",&index,&m); 
            for(j = 0;j < m;j++) 
            { 
                scanf("%d",&vex); 
                next[top] = head[index]; 
                num[top] = vex; 
                head[index] = top++; 
                next[top] = head[vex]; 
                num[top] = index; 
                head[vex] = top++; 
            } 
        } 
        printf("%d\n",KM()/2); 
    } 
    return 0; 
} 

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved