程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU 4648 Magic Pen 6

HDU 4648 Magic Pen 6

編輯:C++入門知識

Magic Pen 6
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 797    Accepted Submission(s): 282

 


Problem Description
In HIT, many people have a magic pen. Lilu0355 has a magic pen, darkgt has a magic pen, discover has a magic pen. Recently, Timer also got a magic pen from seniors.

At the end of this term, teacher gives Timer a job to deliver the list of N students who fail the course to dean's office. Most of these students are Timer's friends, and Timer doesn't want to see them fail the course. So, Timer decides to use his magic pen to scratch out consecutive names as much as possible. However, teacher has already calculated the sum of all students' scores module M. Then in order not to let the teacher find anything strange, Timer should keep the sum of the rest of students' scores module M the same.

Plans can never keep pace with changes, Timer is too busy to do this job. Therefore, he turns to you. He needs you to program to "save" these students as much as possible.
 


Input
There are multiple test cases.
The first line of each case contains two integer N and M, (0< N <= 100000, 0 < M < 10000),then followed by a line consists of N integers a1,a2,...an (-100000000 <= a1,a2,...an <= 100000000) denoting the score of each student.(Strange score? Yes, in great HIT, everything is possible)

 


Output
For each test case, output the largest number of students you can scratch out.
 


Sample Input
2 3
1 6
3 3
2 3 6
2 5
1 3


Sample Output
1
2
0
Hint
The magic pen can be used only once to scratch out consecutive students.
 


Source
2013 Multi-University Training Contest 5
 


Recommend
zhuyuanchen520
我對這題直接無語了,不應該啊,按理說他的余數應該要考慮正負啊,怎麼題目的數據沒有考慮呢,從題目的數據來看出現了負的余數,就把他化成正的,進行統一。這萬一原來的余數是正的,你去掉後余數變成負的顯然不滿足啊。

#include <iostream>   
#include <cstdio>   
#include <cstring>   
#include <cmath>   
#include <map>   
#define N 110000   
using namespace std;  
int a[N];  
int main()  
{  
    //freopen("data.in","r",stdin);   
    int n,m;  
    while(scanf("%d %d",&n,&m)!=EOF)  
    {  
        for(int i=1;i<=n;i++)  
        {  
            scanf("%d",&a[i]);  
        }  
        map<int,int>p;  
        p.clear();  
        int s = 0;  
        int Max = 0;  
        for(int i=1;i<=n;i++)  
        {  
            s +=a[i];  
            s = (s%m+m)%m;  
            if(s==0)  
            {  
                Max = max(Max,i);  
            }  
            if(p[s]==0)  
            {  
                p[s] = i;  
            }else  
            {  
                Max = max(i-p[s],Max);  
            }  
        }  
        printf("%d\n",Max);  
    }  
    return 0;  
}  

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <map>
#define N 110000
using namespace std;
int a[N];
int main()
{
    //freopen("data.in","r",stdin);
    int n,m;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        map<int,int>p;
        p.clear();
        int s = 0;
        int Max = 0;
        for(int i=1;i<=n;i++)
        {
            s +=a[i];
            s = (s%m+m)%m;
            if(s==0)
            {
                Max = max(Max,i);
            }
            if(p[s]==0)
            {
                p[s] = i;
            }else
            {
                Max = max(i-p[s],Max);
            }
        }
        printf("%d\n",Max);
    }
    return 0;
}


 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved