程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> POJ2342:Anniversary party(樹形DP)

POJ2342:Anniversary party(樹形DP)

編輯:C++入門知識

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output

Output should contain the maximal sum of guests' ratings.
Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output

5 題意:有n個人,接下來n行是n個人的價值,再接下來n行給出l,k說的是l的上司是k,這裡注意l與k是不能同時出現的思路:用dp數據來記錄價值,開數組用下標記錄去或者不去、則狀態轉移方程為:DP[i][1] += DP[j][0],DP[i][0] += max{DP[j][0],DP[j][1]};其中j為i的孩子節點。這樣,從根節點r進行dfs,最後結果為max{DP[r][0],DP[r][1]}。

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int father[6005],vis[6005],dp[6005][2],t;

void dfs(int node)
{
    int i,j;
    vis[node] = 1;
    for(i = 1;i<=t;i++)
    {
       if(!vis[i] && father[i] == node)
       {
           dfs(i);
           dp[node][1]+=dp[i][0];//node去,則i必不能去
           dp[node][0]+=max(dp[i][0],dp[i][1]);//node不去,取i去或不去的最大值
       }
    }
}

int main()
{
    int i,j,l,k,root;
    while(~scanf("%d",&t))
    {
        for(i = 1;i<=t;i++)
        scanf("%d",&dp[i][1]);
        root = 0;
        while(scanf("%d%d",&l,&k),l+k>0)
        {
            father[l] = k;//記錄上司
            root = k;
        }
        memset(vis,0,sizeof(vis));
        dfs(root);
        printf("%d\n",max(dp[root][1],dp[root][0]));
    }

    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved