程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu2594 Simpsons’ Hidden Talents  kmp

hdu2594 Simpsons’ Hidden Talents  kmp

編輯:C++入門知識

Simpsons’ Hidden Talents
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1746 Accepted Submission(s): 637

 

Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.


Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.


Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.


Sample Input
clinton
homer
riemann
marjorie

Sample Output
0
rie 3這樣的題,我們很容易就想到了kmp,kmp要理解清楚,這題也就不難了,getnext,中,我們把next 和kmp中是一樣的,只是,就算已經匹配,也不停,一直走到最後去,不就保證了,是str的後綴,且是pass的前綴了麼!

#include <iostream>  
#include <stdio.h>  
#include <string.h> 
 using namespace std; 
 #define  MAXN 50050  
char str[MAXN],pass[MAXN];
  int next[MAXN],strnum,passlen;  void getnext()  {      int i,j;  
    next[0]=next[1]=0;   
   for(i=1,j=0;i<passlen;i++)      {          j=next[i]; 
         while(j&&pass[i]!=pass[j])       
   {              j=next[j];  
        }      
    next[i+1]=pass[i]==pass[j]?j+1:0;  
    }      /*  
    for(i=0;i<passlen;i++)      {          printf("%d ",next[i]);  
    }*/  }  int main()  {      int i,j;    
  while(scanf("%s%s",pass,str)!=EOF)   
   {          strnum=strlen(str);    
      passlen=strlen(pass);          getnext();    
      for(i=0,j=0;i<strnum;i++)          {     
         while(j&&str[i]!=pass[j])             
 {                  j=next[j];              }            
  if(str[i]==pass[j])              {                  j++;      
        }          }            if(j)          printf("%s %d\n",str+strnum-j,j);   
       else          {              printf("0\n");   
       }      }        return 0;  }  

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved