程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU1011:Starship Troopers(樹形DP)

HDU1011:Starship Troopers(樹形DP)

編輯:C++入門知識

Problem Description
You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.

 


Input
The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.

 


Output
For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.

 


Sample Input
5 10
50 10
40 10
40 20
65 30
70 30
1 2
1 3
2 4
2 5
1 1
20 7
-1 -1


Sample Output
50
7

 

題意:給出每個房間擁有的BUG數和能得到的能量數,然後給出每個房間的聯通圖,要到下一個房間必須攻破上一個房間,每個士兵最多消滅20個BUG,就算不足20個BUG也要安排一個士兵

思路:先建立樹,然後進行樹形DP

 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int n,m,len;
int dp[105][105];//dp表示在i點放j人能得到的能量
int bug[105],p[105],vis[105],head[105];

struct node
{
    int now,next;
} tree[105];

void add(int x,int y)
{
    tree[len].now = y;
    tree[len].next = head[x];
    head[x] = len++;
}

void dfs(int root)
{
    int cost,i,j,k,son;
    vis[root] = 1;
    cost = (bug[root]+19)/20;//不足20的部分也要安排一個
    for(i = cost; i<=m; i++)
        dp[root][i] = p[root];//小於cost的無法獲得經驗
    for(i = head[root]; i!=-1; i = tree[i].next)
    {
        son = tree[i].now;
        if(!vis[son])
        {
            dfs(son);
            for(j = m; j>=cost; j--)
            {
                for(k = 1; j+k<=m; k++)
                {
                    if(dp[son][k])//到達r的有j+k人,如果留在r有j人,則到達後繼節點有k人
                        dp[root][j+k] = max(dp[root][j+k],dp[root][j]+dp[son][k]);
                }
            }
        }
    }
}

int main()
{
    int i,j,x,y;
    while(~scanf("%d%d",&n,&m),n+m>0)
    {
        for(i = 1; i<=n; i++)
            scanf("%d%d",&bug[i],&p[i]);
        len = 0;
        memset(vis,0,sizeof(vis));
        memset(head,-1,sizeof(head));
        for(i = 1; i<n; i++)
        {
            scanf("%d%d",&x,&y);
            add(x,y);
            add(y,x);
        }
        if(!m)
        {
            printf("0\n");
            continue;
        }
        memset(dp,0,sizeof(dp));
        dfs(1);
        printf("%d\n",dp[1][m]);
    }

    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved