程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj--1611--並查集(路徑壓縮運用)

poj--1611--並查集(路徑壓縮運用)

編輯:C++入門知識

The Suspects
Time Limit: 1000MS   Memory Limit: 20000K
Total Submissions: 18782   Accepted: 9084

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0Sample Output

4
1
1

#include <iostream>   
#include<stdio.h>   
#include<stdlib.h>   
using namespace std;  
  
const int MAXN = 30500; /*必須開大點/  
int pa[MAXN];    /*p[x】表示x的父節點  
int rank[MAXN];    /*rank是x的高度的一個上界/  
int num[MAXN];/*num[]//存的集合中的元素個數   
  
void make_init(int x)  
{  
    pa[x] = x;  
    rank[x] = 0;  
    num[x] = 1;  
}  
  
int find_set(int x)  
{  
    int r = x, temp;  
  
    while(pa[r] != r) r = pa[r];  
    while(x != r)  
    {  
        temp = pa[x];  
        pa[x] = r;  
        x = temp;  
    }  
    return x;  
    //if(x != pa[x]) //遞歸壓縮。不太好,容易溢出棧  
    //    pa[x] = find_set(pa[x]);   
    //return pa[x];   
}  
  
void union_set(int x, int y)  
{  
    x = find_set(x);  
    y = find_set(y);  
    if(x == y)return ;  
    if(rank[x] > rank[y])/*讓rank比較高的作為父節點  
    {  
        pa[y] = x;  
        num[x] += num[y];  
    }  
    else   
    {  
        pa[x] = y;  
        if(rank[x] == rank[y])  
            rank[y]++;  
        num[y] += num[x];  
    }  
}  
  
//answer to 1611    
int main()  
{  
    int n, m, x, y, i, t, j;  
    while(scanf("%d%d", &n, &m))  
    {  
        if(m==n && n == 0) break;  
        if(m == 0)  
        {  
            printf("1\n");  
            continue;  
        }  
        for(i = 0; i < n; i++){  
              make_init(i);  
        }      
        for(i = 0; i < m; i++)  
        {  
            scanf("%d", &t);  
            scanf("%d", &x);  
            for(j = 1; j < t; j++){  
                scanf("%d", &y);  
                union_set(x, y);  
                x = y;  
            }  
        }  
        x = find_set(0);           
        printf("%d\n",num[x]);  
    }  
    return 0;  
}  

    //    pa[x] = find_set(pa[x]);
    //return pa[x];
}

void union_set(int x, int y)
{
    x = find_set(x);
    y = find_set(y);
    if(x == y)return ;
    if(rank[x] > rank[y])/*讓rank比較高的作為父節點
    {
        pa[y] = x;
        num[x] += num[y];
    }
    else 
    {
        pa[x] = y;
        if(rank[x] == rank[y])
            rank[y]++;
        num[y] += num[x];
    }
}

//answer to 1611 
int main()
{
    int n, m, x, y, i, t, j;
    while(scanf("%d%d", &n, &m))
    {
        if(m==n && n == 0) break;
        if(m == 0)
        {
        	printf("1\n");
            continue;
        }
        for(i = 0; i < n; i++){
        	  make_init(i);
        }    
        for(i = 0; i < m; i++)
        {
            scanf("%d", &t);
            scanf("%d", &x);
            for(j = 1; j < t; j++){
                scanf("%d", &y);
                union_set(x, y);
                x = y;
            }
        }
        x = find_set(0);         
        printf("%d\n",num[x]);
    }
    return 0;
} 

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved