程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu4055 Number String

hdu4055 Number String

編輯:C++入門知識

Number String Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1027 Accepted Submission(s): 448     Problem Description The signature of a permutation is a string that is computed as follows: for each pair of consecutive elements of the permutation, write down the letter 'I' (increasing) if the second element is greater than the first one, otherwise write down the letter 'D' (decreasing). For example, the signature of the permutation {3,1,2,7,4,6,5} is "DIIDID".   Your task is as follows: You are given a string describing the signature of many possible permutations, find out how many permutations satisfy this signature.   Note: For any positive integer n, a permutation of n elements is a sequence of length n that contains each of the integers 1 through n exactly once.   Input Each test case consists of a string of 1 to 1000 characters long, containing only the letters 'I', 'D' or '?', representing a permutation signature.   Each test case occupies exactly one single line, without leading or trailing spaces.   Proceed to the end of file. The '?' in these strings can be either 'I' or 'D'.   Output For each test case, print the number of permutations satisfying the signature on a single line. In case the result is too large, print the remainder modulo 1000000007.   Sample Input II ID DI DD ?D ??   Sample Output 1 2 2 1 3 6 Hint   Permutation {1,2,3} has signature "II". Permutations {1,3,2} and {2,3,1} have signature "ID". Permutations {3,1,2} and {2,1,3} have signature "DI". Permutation {3,2,1} has signature "DD". "?D" can be either "ID" or "DD". "??" gives all possible permutations of length 3.     Author HONG, Qize   Source 2011 Asia Dalian Regional Contest   Recommend lcy 很明顯的dp,我們可以得到壯態轉移方程 ,如果是增dp[i][j]=sum(dp[i-1][1-j-1]),如果是減 ,我們可以 得到dp[i][j]=sum(dp[i-1][j-i-1]);這樣,馬上就可以得出結果了!

#include <iostream>  
#include <stdio.h>  
#include <string.h>  
#define mod 1000000007  
using namespace std;  
char str[1050];  
int dp[1050][1050],sum[1050][1050];  
int main()  
{  
    int i,j;  
   while(scanf("%s",str)!=EOF)  
   {  
       memset(dp,0,sizeof(dp));  
       sum[1][1]=1;  
       int strnum=strlen(str);  
       for(i=2;i<=strnum+1;i++)  
       {  
            for(j=1;j<=i;j++)  
               {  
                     if(str[i-2]=='I'||str[i-2]=='?')  
                   {  
  
                           dp[i][j]=(dp[i][j]+sum[i-1][j-1])%mod;  
                   }  
                    if(str[i-2]=='D'||str[i-2]=='?')  
                   {  
  
                     dp[i][j]=(dp[i][j]+((sum[i-1][i-1]-sum[i-1][j-1])%mod+mod)%mod)%mod;  
  
                   }  
                   sum[i][j]=(sum[i][j-1]+dp[i][j])%mod;  
               }  
        }  
        printf("%d\n",sum[strnum+1][strnum+1]);  
   }  
    return 0;  
}  

 


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved