程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> 299 Train Swapping(列車交換)

299 Train Swapping(列車交換)

編輯:C++入門知識

At an old railway station, you may still encounter one of the last remaining ``train swappers''. A train swapper is an employee of the railroad, whose sole job it is to rearrange the carriages of trains.

Once the carriages are arranged in the optimal order, all the train driver has to do, is drop the carriages off, one by one, at the stations for which the load is meant.


The title ``train swapper'' stems from the first person who performed this task, at a station close to a railway bridge. Instead of opening up vertically, the bridge rotated around a pillar in the center of the river. After rotating the bridge 90 degrees, boats could pass left or right.

The first train swapper had discovered that the bridge could be operated with at most two carriages on it. By rotating the bridge 180 degrees, the carriages switched place, allowing him to rearrange the carriages (as a side effect, the carriages then faced the opposite direction, but train carriages can move either way, so who cares).

Now that almost all train swappers have died out, the railway company would like to automate their operation. Part of the program to be developed, is a routine which decides for a given train the least number of swaps of two adjacent carriages necessary to order the train. Your assignment is to create that routine.


Input Specification
The input contains on the first line the number of test cases (N). Each test case consists of two input lines. The first line of a test case contains an integer L, determining the length of the train (  ). The second line of a test case contains a permutation of the numbers 1 through L, indicating the current order of the carriages. The carriages should be ordered such that carriage 1 comes first, then 2, etc. with carriage L coming last.


Output Specification
For each test case output the sentence: 'Optimal train swapping takes S swaps.' where S is an integer.


Example Input

3
3
1 3 2
4
4 3 2 1
2
2 1
Example Output

Optimal train swapping takes 1 swaps.
Optimal train swapping takes 6 swaps.
Optimal train swapping takes 1 swaps.

 


題目要求:

細細看題目會發現,實際上就是冒泡排序(升序排列),記錄交換的次數。

 

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define swap(m,n) {(m)=(m)^(n);(n)=(m)^(n);(m)=(m)^(n);}
int main(){
    int T, n, i, j;
    int num[55];
    int count;

    scanf("%d", &T);
    while(T--){
        scanf("%d", &n);
        memset(num, 0, sizeof(num));
        for(i = 0; i<n; i++)
            scanf("%d", &num[i]);

        count = 0;
        for(i = 0; i<n-1; i++){
            for(j = 1; j<n-i; j++){
                if(num[j-1]>num[j]){
                    count++;
                    swap(num[j-1], num[j]);
                }
            }
        }

        printf("Optimal train swapping takes %d swaps.\n", count);
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved