程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> POJ 1287 Networking

POJ 1287 Networking

編輯:C++入門知識

Networking
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 5417   Accepted: 2915

Description

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area.
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.
Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line.
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i.

Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.
Sample Input

1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0Sample Output

0
17
16
26題意:

一幅無向圖,求最小生成樹。 這道題要注意的是兩個點之間可能不止一條路徑。由於這道題數據量較小,所以prime和krusical都可以用

 


 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define INF 10000
using namespace std;
int map[55][55];
int prime(int p)
{
    int visit[55]= {0},low[55],i,j,k,ans=0;
    int t=INF;
    visit[1]=1;
    for (i=1; i<=p; i++)
        low[i]=map[1][i];
    for (i=1; i<p; i++)
    {
        t=INF;
        for (j=1; j<=p; j++)
            if (!visit[j] && low[j]<t)
            {
                t=low[j];
                k=j;
            }
        ans+=low[k];
        visit[k]=1;
        for (j=1; j<=p; j++)
            if (!visit[j] && low[j]>map[k][j])
                low[j]=map[k][j];
    }
    return ans;
}
struct node
{
    int x,y,s;
} e[55*55/2];
bool cmp(node s, node v)
{
    return s.s<v.s;
}
int f[55];
int find(int x)
{
    if (x==f[x]) return x;
    f[x]=find(f[x]);
    return f[x];
}
int krusical(int p)
{
    int t=0,i,j,visit[55]={0},ans=0;
    for (i=1; i<p; i++)
        for (j=i+1; j<=p; j++)
            if (map[i][j]!=INF)
            {
                e[t].x=i;
                e[t].y=j;
                e[t].s=map[i][j];
                t++;
            }
    sort(e,e+t,cmp);
    for (i=1; i<=p; i++)
        f[i]=i;
    for (i=0; i<t; i++)
    {
        if (find(e[i].x)!=find(e[i].y))
        {
            f[find(e[i].x)]=f[find(e[i].y)];
            ans+=e[i].s;
        }
    }
    return ans;
}
int main ()
{
    int p,r,i,j;
    while(cin>>p)
    {
        for (i=0; i<=p; i++)
            for (j=0; j<=p; j++)
                map[i][j]=INF;
        if (p==0) break;
        cin>>r;
        if (r==0) cout<<0<<endl;
        else
        {
            while(r--)
            {
                int a,b,c;
                cin>>a>>b>>c;
                if (map[a][b]>c)
                {
                    map[a][b]=c;
                    map[b][a]=c;
                }
            }
            cout<<krusical(p)<<endl;
            //cout<<prime(p)<<endl;
        }
    }
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved