程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu1700 Points on Cycle (數學)

hdu1700 Points on Cycle (數學)

編輯:C++入門知識

Problem Description
There is a cycle with its center on the origin.
Now give you a point on the cycle, you are to find out the other two points on it, to maximize the sum of the distance between each other
you may assume that the radius of the cycle will not exceed 1000.


Input
There are T test cases, in each case there are 2 decimal number representing the coordinate of the given point.


Output
For each testcase you are supposed to output the coordinates of both of the unknow points by 3 decimal places of precision
Alway output the lower one first(with a smaller Y-coordinate value), if they have the same Y value output the one with a smaller X.


NOTE
when output, if the absolute difference between the coordinate values X1 and X2 is smaller than 0.0005, we assume they are equal.


Sample Input
2
1.500 2.000
563.585 1.251

Sample Output
0.982 -2.299 -2.482 0.299
-280.709 -488.704 -282.876 487.453

#include<stdio.h>   #include<math.h>   int main()  {      int t;      double x[3],y[3],c[2],a,b;      scanf("%d",&t);      while(t--)      {          scanf("%lf%lf",&x[0],&y[0]);          c[0]=x[0]*x[0]+y[0]*y[0];          if(x[0]==0)          {              y[1]=y[2]=-y[0]/2;              x[1]=-sqrt(c[0]-y[1]*y[1]);              x[2]=sqrt(c[0]-y[2]*y[2]);          }          else          {              c[1]=-c[0]+c[0]*c[0]/(4*x[0]*x[0]);              b=c[0]*y[0]/(x[0]*x[0]);              a=1+y[0]*y[0]/(x[0]*x[0]);              y[1]=(-b-sqrt(b*b-4*a*c[1]))/(2*a);              y[2]=(-b+sqrt(b*b-4*a*c[1]))/(2*a);              x[1]=-c[0]/(2*x[0])-y[0]*y[1]/x[0];              x[2]=-c[0]/(2*x[0])-y[0]*y[2]/x[0];          }          printf("%.3lf %.3lf %.3lf %.3lf\n",x[1],y[1],x[2],y[2]);      }  }  #include<stdio.h>
#include<math.h>
int main()
{
    int t;
    double x[3],y[3],c[2],a,b;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf",&x[0],&y[0]);
        c[0]=x[0]*x[0]+y[0]*y[0];
        if(x[0]==0)
        {
            y[1]=y[2]=-y[0]/2;
            x[1]=-sqrt(c[0]-y[1]*y[1]);
            x[2]=sqrt(c[0]-y[2]*y[2]);
        }
        else
        {
            c[1]=-c[0]+c[0]*c[0]/(4*x[0]*x[0]);
            b=c[0]*y[0]/(x[0]*x[0]);
            a=1+y[0]*y[0]/(x[0]*x[0]);
            y[1]=(-b-sqrt(b*b-4*a*c[1]))/(2*a);
            y[2]=(-b+sqrt(b*b-4*a*c[1]))/(2*a);
            x[1]=-c[0]/(2*x[0])-y[0]*y[1]/x[0];
            x[2]=-c[0]/(2*x[0])-y[0]*y[2]/x[0];
        }
        printf("%.3lf %.3lf %.3lf %.3lf\n",x[1],y[1],x[2],y[2]);
    }
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved