程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU 1104 Remainder (BFS(廣度優先搜索))

HDU 1104 Remainder (BFS(廣度優先搜索))

編輯:C++入門知識

Remainder
Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2260 Accepted Submission(s): 481

 

Problem Description
Coco is a clever boy, who is good at mathematics. However, he is puzzled by a difficult mathematics problem. The problem is: Given three integers N, K and M, N may adds (‘+’) M, subtract (‘-‘) M, multiples (‘*’) M or modulus (‘%’) M (The definition of ‘%’ is given below), and the result will be restored in N. Continue the process above, can you make a situation that “[(the initial value of N) + 1] % K” is equal to “(the current value of N) % K”? If you can, find the minimum steps and what you should do in each step. Please help poor Coco to solve this problem.

You should know that if a = b * q + r (q > 0 and 0 <= r < q), then we have a % q = r.

 

Input
There are multiple cases. Each case contains three integers N, K and M (-1000 <= N <= 1000, 1 < K <= 1000, 0 < M <= 1000) in a single line.

The input is terminated with three 0s. This test case is not to be processed.

 

Output
For each case, if there is no solution, just print 0. Otherwise, on the first line of the output print the minimum number of steps to make “[(the initial value of N) + 1] % K” is equal to “(the final value of N) % K”. The second line print the operations to do in each step, which consist of ‘+’, ‘-‘, ‘*’ and ‘%’. If there are more than one solution, print the minimum one. (Here we define ‘+’ < ‘-‘ < ‘*’ < ‘%’. And if A = a1a2...ak and B = b1b2...bk are both solutions, we say A < B, if and only if there exists a P such that for i = 1, ..., P-1, ai = bi, and for i = P, ai < bi)

 

Sample Input
2 2 2
-1 12 10
0 0 0

Sample Output
0
2
*+BFS(廣度優先搜索)

import java.io.*;
import java.util.*;

public class Main {
	public String str="+-*%";
	public int n,m,k,sum,km;
	public boolean boo[]=new boolean[1000*1000*10+1];
	public Queue<Node1> list=new LinkedList<Node1>();
	public static void main(String[] args) {
		
		new Main().work();
	}
	public void work(){
		Scanner sc=new Scanner(new BufferedInputStream(System.in));
		while(sc.hasNext()){
			list.clear();
			Arrays.fill(boo,false);
			n=sc.nextInt();
			k=sc.nextInt();
			m=sc.nextInt();
			if(n==0&&k==0&&m==0)
				System.exit(0);
			Node1 node=new Node1();
			node.n=n;
			node.s="";
			sum=getMode(n+1,k);
			km=m*k;
			boo[getMode(n,km)]=true;
			list.add(node);
			BFS();
		}
	}
	public void BFS(){
		while(!list.isEmpty()){
			Node1 node=list.poll();
			if(getMode(node.n,k)==sum){
				System.out.println(node.s.length());
				System.out.println(node.s);
				return;
			}
			for(int i=0;i<str.length();i++){
				int temp=0;
				if(str.charAt(i)=='+'){
					temp=getMode(node.n+m,km);
				}
				else if(str.charAt(i)=='-'){
					temp=getMode(node.n-m,km);
				}
				else if(str.charAt(i)=='*'){
					temp=getMode(node.n*m,km);
				}
				else if(str.charAt(i)=='%'){
					temp=getMode(getMode(node.n,m),km);
				}
				if(!boo[temp]){
					boo[temp]=true;
					Node1 t=node.getNode();
					t.n=temp;
					t.s=t.s+str.charAt(i);
					list.add(t);
				}
			}
		}
		System.out.println(0);
	}
	public  int getMode(int a,int b){
		return (a%b+b)%b;
	}
}
class Node1{
	int n;
	String s;
	Node1(){
		n=0;
		s="";
	}
	public Node1 getNode(){
		Node1 node=new Node1();
		node.n=0;
		node.s=s;
		return node;
	}
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved