程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> UVA 270 Lining Up (幾何 判斷共線點)

UVA 270 Lining Up (幾何 判斷共線點)

編輯:C++入門知識

 Lining Up 


``How am I ever going to solve this problem?" said the pilot.


Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?


Your program has to be efficient!


Input
The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
The input consists of N pairs of integers, where 1 < N < 700. Each pair of integers is separated by one blank and ended by a new-line character. The list of pairs is ended with an end-of-file character. No pair will occur twice.


Output
For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.
The output consists of one integer representing the largest number of points that all lie on one line.


Sample Input

1

1 1
2 2
3 3
9 10
10 11
Sample Output

3

題意:給定一些點坐標。求共線點最多的個數。。

思路:我的做法是暴力枚舉。每次先枚舉出2個點。作為直線。再去枚舉第三個點看在不在直線上。 可以推出一個公式

y(x1 - x2) = (y1 - y2) * x + y2 * x1 - y1 * x2的時候。為(x,y)在(x1,y1)和(x2,y2)組成的直線上。。不過這樣做的話時間復雜度為O(n^3)..中間有個優化。就是如果兩個點之前判斷連接過了。之後在遇到就直接跳過。。但是依然跑了快2秒。- -

 


看網上別人做法有一種時間復雜度為O(n^2logn)的做法。。是每次枚舉一個點作為原點。然後把其他點和它的斜率算出來。然後找出這些斜率中相同斜率出現次數最多的作為最大值。感覺不錯。

我的代碼:

 

#include <stdio.h>
#include <string.h>

int t;
int n, i, j, k, l;
int max, ans;
int vis[705][705];
int mark[705];
char sb[30];

struct Point {
	int x, y;
} p[705];

int main() {
	scanf("%d%*c%*c", &t);
	while (t --) {
		n = 0; max = 0;
		memset(vis, 0, sizeof(vis));
		while (gets(sb) && sb[0] != '\0') {
			sscanf(sb, "%d%d", &p[n].x, &p[n].y);
			n ++;
		}
		for (i = 0; i < n; i ++)
			for (j = i + 1; j < n; j ++) {
				if (vis[i][j]) continue;
				ans = 0;
				for (k = 0; k < n; k ++) {
					if (p[k].y * (p[i].x - p[j].x) == (p[i].y - p[j].y) * p[k].x + p[j].y * p[i].x - p[i].y * p[j].x) {
						mark[ans ++] = k;
						for (l = 0; l < ans - 1; l ++)
							vis[k][mark[l]] = vis[mark[l]][k] = 1;
					}
				}
				if (max < ans)
					max = ans;
			}
		printf("%d\n", max);
		if (t) printf("\n");
	}
	return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved