程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> UVA 10020 Minimal coverage(貪心 + 區間覆蓋問題)

UVA 10020 Minimal coverage(貪心 + 區間覆蓋問題)

編輯:C++入門知識

 Minimal coverage 

 

The Problem
Given several segments of line (int the X axis) with coordinates [Li,Ri]. You are to choose the minimal amount of them, such they would completely cover the segment [0,M].


The Input

The first line is the number of test cases, followed by a blank line.

Each test case in the input should contains an integer M(1<=M<=5000), followed by pairs "Li Ri"(|Li|, |Ri|<=50000, i<=100000), each on a separate line. Each test case of input is terminated by pair "0 0".

Each test case will be separated by a single line.


The Output
For each test case, in the first line of output your programm should print the minimal number of line segments which can cover segment [0,M]. In the following lines, the coordinates of segments, sorted by their left end (Li), should be printed in the same format as in the input. Pair "0 0" should not be printed. If [0,M] can not be covered by given line segments, your programm should print "0"(without quotes).

Print a blank line between the outputs for two consecutive test cases.


Sample Input

2

1
-1 0
-5 -3
2 5
0 0

1
-1 0
0 1
0 0

Sample Output

0

1
0 1


題意:給定一個M,和一些區間[Li,Ri]。。要選出幾個區間能完全覆蓋住[0,M]區間。要求數量最少。。如果不能覆蓋輸出0.

思路:貪心的思想。。把區間按Ri從大到小排序。 然後遇到一個滿足的[Li,Ri],就更新縮小區間。。直到完全覆蓋。


注意[Li,Ri]只有滿足Li小於等於且Ri大於當前覆蓋區間左端這個條件。才能選中。


代碼:


 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int t;
int start, end, qn, outn;
struct M {
    int start;
    int end;
} q[100005], out[100005];

int cmp (M a, M b) {//按最大能覆蓋到排序
    return a.end > b.end;
}
int main() {
    scanf("%d", &t);
    while (t --) {
	qn = 0; outn = 0; start = 0;
	scanf("%d", &end);
	while (~scanf("%d%d", &q[qn].start, &q[qn].end) && q[qn].start + q[qn].end) {
	    qn ++;
	}
	sort(q, q + qn, cmp);
	while (start < end) {
	    int i;
	    for (i = 0; i < qn; i ++) {
		if (q[i].start <= start && q[i].end > start) {
		    start = q[i].end;//更新區間
		    out[outn ++] = q[i];
		    break;
		}
	    }
	    if (i == qn) break;//如果沒有一個滿足條件的區間,直接結束。
	}
	if (start < end) printf("0\n");
	else {
	    printf("%d\n", outn);
	    for (int i = 0; i < outn; i ++)
		printf("%d %d\n", out[i].start, out[i].end);
	}
	if (t) printf("\n");
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved