程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> uva 424

uva 424

編輯:C++入門知識

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output
Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input
123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0
Sample Output
370370367037037036703703703670


 

#include <stdio.h>
#include <string.h>
#define N 100
char str[N+10][N+10];
char str_sum[N+10];
int s1[N+10][N+10];
int sum[N+10];

int main()
{
     int i = 0,j,k,len,flag;
     while(gets(str[i]))
     {
          if(str[i][0] == '0' && str[i][1] == '\0')
          {
               break;
          }
          len = strlen(str[i]);
          j = 0;
          for(k = len - 1; k >= 0; k--)
          {
               s1[i][j++] = str[i][k] - '0';
          }
          for(j = 0; j < N+10; j++)
          {
               sum[j] += s1[i][j];          
          }
          i++;
     } 
     for(i = 0; i < N + 10; i++)
     {
          if(sum[i] >= 10)
          {
               flag = sum[i];
               sum[i] = flag%10;
               sum[i+1] += flag/10;
          }
     }
     flag = 0;
     for(i=N+5; i>=0; i--)
     {
          if(flag)
          {
               printf("%d", sum[i]);
          }
          else if(sum[i])
          {
               printf("%d", sum[i]);
               flag = 1;
          }
     }
     if(!flag)
     {
          printf("0");
     }
     printf("\n");
     return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved