程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> uva 537

uva 537

編輯:C++入門知識

Physics teachers in high school often think that problems given as text are more demanding than pure computations. After all, the pupils have to read and understand the problem first!

So they don't state a problem like ``U=10V, I=5A, P=?" but rather like ``You have an electrical circuit that contains a battery with a voltage of U=10V and a light-bulb. There's an electrical current of I=5A through the bulb. Which power is generated in the bulb?".

However, half of the pupils just don't pay attention to the text anyway. They just extract from the text what is given: U=10V, I=5A. Then they think: ``Which formulae do I know? Ah yes, P=U*I. Therefore P=10V*5A=500W. Finished."

OK, this doesn't always work, so these pupils are usually not the top scorers in physics tests. But at least this simple algorithm is usually good enough to pass the class. (Sad but true.)

Today we will check if a computer can pass a high school physics test. We will concentrate on the P-U-I type problems first. That means, problems in which two of power, voltage and current are given and the third is wanted.


Your job is to write a program that reads such a text problem and solves it according to the simple algorithm given above.

Input
The first line of the input file will contain the number of test cases.
Each test case will consist of one line containing exactly two data fields and some additional arbitrary words. A data field will be of the form I=xA, U=xV or P=xW, where x is a real number.

Directly before the unit (A, V or W) one of the prefixes m (milli), k (kilo) and M (Mega) may also occur. To summarize it: Data fields adhere to the following grammar:

DataField ::= Concept '=' RealNumber [Prefix] Unit
Concept   ::= 'P' | 'U' | 'I'
Prefix    ::= 'm' | 'k' | 'M'
Unit      ::= 'W' | 'V' | 'A'
Additional assertions:

The equal sign (`=') will never occur in an other context than within a data field.
There is no whitespace (tabs,blanks) inside a data field.
Either P and U, P and I, or U and I will be given.
Output
For each test case, print three lines:
a line saying ``Problem #k" where k is the number of the test case
a line giving the solution (voltage, power or current, dependent on what was given), written without a prefix and with two decimal places as shown in the sample output
a blank line
Sample Input
3
If the voltage is U=200V and the current is I=4.5A, which power is generated?
A light-bulb yields P=100W and the voltage is U=220V. Compute the current, please.
bla bla bla lightning strike I=2A bla bla bla P=2.5MW bla bla voltage?
Sample Output
Problem #1
P=900.00W

Problem #2
I=0.45A

Problem #3
U=1250000.00V

 


#include <stdio.h>
#include <string.h>
#define N 1000

char s[N];
char f1[] = "UIP";
char f2[] = "mkM";
char f3[] = "VAW";
double sum[3];
double r[3] = {0.001,1000.00,1000000.00};
char pre;
int main()
{
     int t,j,flag,i,k;
     int count = 1;
     double res;
     scanf("%d", &t);
     getchar();
     while(t--)
     {
          memset(sum,0,sizeof(sum));
          gets(s);
          for(i = 0; i < strlen(s); i++)
          {
               if(s[i+1] == '=')
               {
                    for(j = 0; f1[j] != s[i]; j++)
                    {
                         ;
                    }
                    sscanf(&s[i]+2,"%lf%c",&sum[j],&pre);
                    for(k = 0; k < 3; k++)
                    {
                         if(pre == f2[k])
                         {
                              sum[j] *= r[k];
                         }
                    }
               }
          }
          for(i = 0; i < 3; i++)
          {
               if(sum[i] == 0)
               {
                    flag=i;
               }
          }
          if(flag==0)
          {
               res = sum[2]/sum[1];
          }
          else if(flag==1)
          {
               res = sum[2]/sum[0];
          }
          else
          {
               res = sum[0]*sum[1];
          }
          printf("Problem #%d\n%c=%.2lf%c\n\n",count++,f1[flag],res,f3[flag]);
     }     return 0;
}
這裡的sscanf()用的非常巧妙  省了很多行代碼

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved