程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu1839之二分+鄰接表+Dijkstra+隊列優化

hdu1839之二分+鄰接表+Dijkstra+隊列優化

編輯:C++入門知識

Delay Constrained Maximum Capacity Path
Time Limit: 10000/10000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 544    Accepted Submission(s): 192


Problem Description
Consider an undirected graph with N vertices, numbered from 1 to N, and M edges. The vertex numbered with 1 corresponds to a mine from where some precious minerals are extracted. The vertex numbered with N corresponds to a minerals processing factory. Each edge has an associated travel time (in time units) and capacity (in units of minerals). It has been decided that the minerals which are extracted from the mine will be delivered to the factory using a single path. This path should have the highest capacity possible, in order to be able to transport simultaneously as many units of minerals as possible. The capacity of a path is equal to the smallest capacity of any of its edges. However, the minerals are very sensitive and, once extracted from the mine, they will start decomposing after T time units, unless they reach the factory within this time interval. Therefore, the total travel time of the chosen path (the sum of the travel times of its edges) should be less or equal to T.

 

Input
The first line of input contains an integer number X, representing the number of test cases to follow. The first line of each test case contains 3 integer numbers, separated by blanks: N (2 <= N <= 10.000), M (1 <= M <= 50.000) and T (1 <= T <= 500.000). Each of the next M lines will contain four integer numbers each, separated by blanks: A, B, C and D, meaning that there is an edge between vertices A and B, having capacity C (1 <= C <= 2.000.000.000) and the travel time D (1 <= D <= 50.000). A and B are different integers between 1 and N. There will exist at most one edge between any two vertices.

 

Output
For each of the X test cases, in the order given in the input, print one line containing the highest capacity of a path from the mine to the factory, considering the travel time constraint. There will always exist at least one path between the mine and the factory obbeying the travel time constraint.

 

Sample Input
2
2 1 10
1 2 13 10
4 4 20
1 2 1000 15
2 4 999 6
1 3 100 15
3 4 99 4

Sample Output
13
99


題目:給m條管道,每條管道有可運輸的最大容量和消耗的時間c,t

現在有東西要從1運輸到n,必須在時間T內完成,求符合條件的可運輸的最大容量

分析:對於所給的m條管道的最大容量,進行排序,然後二分容量求從1到n的最短時間即可

#include<iostream>   
#include<cstdio>   
#include<cstdlib>   
#include<cstring>   
#include<string>   
#include<queue>   
#include<algorithm>   
#include<map>   
#include<vector>   
#include<iomanip>   
#define INF 99999999   
using namespace std;  
  
const int MAX=10000+10;  
int s[MAX*5],n,m,t;  
int size,head[MAX],dist[MAX];  
bool mark[MAX];  
typedef pair<int,int>mp;  
  
struct Edge{  
    int v,c,t,next;  
    Edge(){}  
    Edge(int &V,int &C,int &T,int NEXT):v(V),c(C),t(T),next(NEXT){}  
}edge[MAX*5*2];  
  
inline void Init(int num){  
    memset(head,-1,sizeof(int)*(num+2));  
    size=0;  
}  
  
inline void InsertEdge(int u,int v,int &c,int &t){  
    edge[size]=Edge(v,c,t,head[u]);//頭插法   
    head[u]=size++;   
}  
  
inline bool Dijkstra(int s,int t,int c,int T){  
    for(int i=1;i<=n;++i)mark[i]=false,dist[i]=INF;  
    dist[s]=0,mark[s]=true;  
    priority_queue< mp,vector<mp>,greater<mp> >q;  
    mp oq;  
    q.push(mp(0,s));  
    while(!q.empty()){  
        oq=q.top();  
        q.pop();  
        if(oq.first>T)return false;  
        if(oq.second == t)return dist[t];//dist[t]<=T;   
        mark[oq.second]=true;  
        for(int i=head[oq.second];i != -1;i=edge[i].next){  
            int v=edge[i].v;  
            if(mark[v] || edge[i].c<c)continue;  
            if(oq.first+edge[i].t<dist[v]){  
                dist[v]=oq.first+edge[i].t;  
                q.push(mp(dist[v],v));  
            }  
        }  
    }  
    return false;//無法到達t    
}  
  
int main(){  
    int num,u,v,c,T;  
    cin>>num;  
    while(num--){  
        scanf("%d%d%d",&n,&m,&t);  
        Init(n);  
        for(int i=0;i<m;++i){  
            scanf("%d%d%d%d",&u,&v,&c,&T);  
            InsertEdge(u,v,c,T);  
            InsertEdge(v,u,c,T);  
            s[i]=c;  
        }  
        sort(s,s+m);  
        int left=0,right=0,mid;  
        for(int i=1;i<m;++i)if(s[i] != s[i-1])s[++right]=s[i];  
        while(left<=right){  
            mid=left+right>>1;  
            if(Dijkstra(1,n,s[mid],t))left=mid+1;  
            else right=mid-1;  
        }  
        printf("%d\n",s[right]);  
    }  
    return 0;  
}  

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<vector>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=10000+10;
int s[MAX*5],n,m,t;
int size,head[MAX],dist[MAX];
bool mark[MAX];
typedef pair<int,int>mp;

struct Edge{
	int v,c,t,next;
	Edge(){}
	Edge(int &V,int &C,int &T,int NEXT):v(V),c(C),t(T),next(NEXT){}
}edge[MAX*5*2];

inline void Init(int num){
	memset(head,-1,sizeof(int)*(num+2));
	size=0;
}

inline void InsertEdge(int u,int v,int &c,int &t){
	edge[size]=Edge(v,c,t,head[u]);//頭插法
	head[u]=size++; 
}

inline bool Dijkstra(int s,int t,int c,int T){
	for(int i=1;i<=n;++i)mark[i]=false,dist[i]=INF;
	dist[s]=0,mark[s]=true;
	priority_queue< mp,vector<mp>,greater<mp> >q;
	mp oq;
	q.push(mp(0,s));
	while(!q.empty()){
		oq=q.top();
		q.pop();
		if(oq.first>T)return false;
		if(oq.second == t)return dist[t];//dist[t]<=T;
		mark[oq.second]=true;
		for(int i=head[oq.second];i != -1;i=edge[i].next){
			int v=edge[i].v;
			if(mark[v] || edge[i].c<c)continue;
			if(oq.first+edge[i].t<dist[v]){
				dist[v]=oq.first+edge[i].t;
				q.push(mp(dist[v],v));
			}
		}
	}
	return false;//無法到達t 
}

int main(){
	int num,u,v,c,T;
	cin>>num;
	while(num--){
		scanf("%d%d%d",&n,&m,&t);
		Init(n);
		for(int i=0;i<m;++i){
			scanf("%d%d%d%d",&u,&v,&c,&T);
			InsertEdge(u,v,c,T);
			InsertEdge(v,u,c,T);
			s[i]=c;
		}
		sort(s,s+m);
		int left=0,right=0,mid;
		for(int i=1;i<m;++i)if(s[i] != s[i-1])s[++right]=s[i];
		while(left<=right){
			mid=left+right>>1;
			if(Dijkstra(1,n,s[mid],t))left=mid+1;
			else right=mid-1;
		}
		printf("%d\n",s[right]);
	}
	return 0;
}






 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved