程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> UVA 507 Jill Rides Again (連續子序列最大和問題)

UVA 507 Jill Rides Again (連續子序列最大和問題)

編輯:C++入門知識

  Jill Rides Again 


Jill likes to ride her bicycle, but since the pretty city of Greenhills where she lives has grown, Jill often uses the excellent public bus system for part of her journey. She has a folding bicycle which she carries with her when she uses the bus for the first part of her trip. When the bus reaches some pleasant part of the city, Jill gets off and rides her bicycle. She follows the bus route until she reaches her destination or she comes to a part of the city she does not like. In the latter event she will board the bus to finish her trip.

 

Through years of experience, Jill has rated each road on an integer scale of ``niceness.'' Positive niceness values indicate roads Jill likes; negative values are used for roads she does not like. There are not zero values. Jill plans where to leave the bus and start bicycling, as well as where to stop bicycling and re-join the bus, so that the sum of niceness values of the roads she bicycles on is maximized. This means that she will sometimes cycle along a road she does not like, provided that it joins up two other parts of her journey involving roads she likes enough to compensate. It may be that no part of the route is suitable for cycling so that Jill takes the bus for its entire route. Conversely, it may be that the whole route is so nice Jill will not use the bus at all.

 

Since there are many different bus routes, each with several stops at which Jill could leave or enter the bus, she feels that a computer program could help her identify the best part to cycle for each bus route.


Input
The input file contains information on several bus routes. The first line of the file is a single integer b representing the number of route descriptions in the file. The identifier for each route (r) is the sequence number within the data file, . Each route description begins with the number of stops on the route: an integer s,  on a line by itself. The number of stops is followed by s - 1 lines, each line i ( ) is an integer ni representing Jill's assessment of the niceness of the road between the two stops i and i+1.

Output
For each route r in the input file, your program should identify the beginning bus stop i and the ending bus stop j that identify the segment of the route which yields the maximal sum of niceness, m= ni+ni+1+...+nj-1. If more than one segment is maximally nice, choose the one with the longest cycle ride (largest j-i). To break ties in longest maximal segments, choose the segment that begins with the earliest stop (lowest i). For each route r in the input file, print a line in the form:


The nicest part of route r is between stops i and j

 

However, if the maximal sum is not positive, your program should print:

 

Route r has no nice parts


Sample Input
3
3
  -1
   6
10
   4
  -5
   4
  -3
   4
   4
  -4
   4
  -5
4
  -2
  -3
  -4

Sample Output
The nicest part of route 1 is between stops 2 and 3
The nicest part of route 2 is between stops 3 and 9
Route 3 has no nice parts題意:題目意思:   有一個人想要騎自行車去旅游,但是現在有s-1條路,每一條都有一個值,正值表示他喜歡然後他會騎自行車,負數表示他不喜歡他做公交。現在問這根騎自行車的最長的道路。
思路: 其實就是求連續子序列最大和的問題。。。不過這題要輸出起點和終點。。


然後。。注意:如果有最大和相同的時候,要輸出序列長度最長的。如果序列長度也相等。。就要輸出起點最小的。。Fxck因為這坑爹的地方wa了好幾次。


代碼:


 

#include <stdio.h>
#include <string.h>
#include <limits.h>

int t, n, sum, value[20005], Max, start, go, end, d;
int main() {
    scanf("%d", &t);
    int No = 1;
    while (t --) {
	scanf("%d", &n);
	Max = -INT_MAX; sum = 0; start = 1, d = 0;
	for (int i = 1; i < n; i ++) {
	    scanf("%d", &value[i]);
	    if (sum >= 0)
		sum += value[i];
	    else {
		start = i;
		sum = value[i];
	    }
	    if (Max <= sum) {
		if ((Max == sum && i + 1 - start > d) || Max < sum) {
		    d = i + 1 - start;
		    go = start;
		    end = i + 1;
		}
		Max = sum;
	    }
	}
	if (Max > 0) 
	    printf("The nicest part of route %d is between stops %d and %d\n", No ++, go, end);
	else
	    printf("Route %d has no nice parts\n", No ++);
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved