程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu4308之BFS

hdu4308之BFS

編輯:C++入門知識

Saving Princess claire_
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2099    Accepted Submission(s): 727


Problem Description
Princess claire_ was jailed in a maze by Grand Demon Monster(GDM) teoy.
Out of anger, little Prince ykwd decides to break into the maze to rescue his lovely Princess.
The maze can be described as a matrix of r rows and c columns, with grids, such as 'Y', 'C', '*', '#' and 'P', in it. Every grid is connected with its up, down, left and right grids.
There is only one 'Y' which means the initial position when Prince ykwd breaks into the maze.
There is only one 'C' which means the position where Princess claire_ is jailed.
There may be many '*'s in the maze, representing the corresponding grid can be passed through with a cost of certain amount of money, as GDM teoy has set a toll station.
The grid represented by '#' means that you can not pass it.
It is said that as GDM teoy likes to pee and shit everywhere, this grid is unfortunately damaged by his ugly behavior.
'P' means it is a transmission port and there may be some in the maze. These ports( if exist) are connected with each other and Prince ykwd can jump from one of them to another.

They say that there used to be some toll stations, but they exploded(surely they didn't exist any more) because of GDM teoy's savage act(pee and shit!), thus some wormholes turned into existence and you know the following things. Remember, Prince ykwd has his mysterious power that he can choose his way among the wormholes, even he can choose to ignore the wormholes.
Although Prince ykwd deeply loves Princess claire_, he is so mean that he doesn't want to spend too much of his money in the maze. Then he turns up to you, the Great Worker who loves moving bricks, for help and he hopes you can calculate the minimum money he needs to take his princess back.
 

Input
Multiple cases.(No more than fifty.)
The 1st line contains 3 integers, r, c and cost. 'r', 'c' and 'cost' is as described above.(0 < r * c <= 5000 and money is in the range of (0, 10000] )
Then an r * c character matrix with 'P' no more than 10% of the number of all grids and we promise there will be no toll stations where the prince and princess exist.

 

Output
One line with an integer, representing the minimum cost. If Prince ykwd cannot rescue his princess whatever he does, then output "Damn teoy!".(See the sample for details.)
 

Sample Input
1 3 3
Y*C

1 3 2
Y#C

1 5 2
YP#PC

Sample Output
3
Damn teoy!
0
題意:給定n行m列地圖,每走一步'*'格子花費v的代價,遇到'p'可以直接跳到所有的p位置去,問從y到c的最小花費

分析:裸的BFS,遇到p就把所有含有p的位置放到隊列中並標記,然後繼續搜就行了,注意把所有的p位置放到隊列中要把以前隊列含有的點出隊列在放進隊列或者用優先隊列,因為原來在隊列中的點的花費的價值可能更大

#include<iostream>   
#include<cstdio>   
#include<cstdlib>   
#include<cstring>   
#include<string>   
#include<queue>   
#include<algorithm>   
#include<map>   
#include<iomanip>   
#define INF 99999999   
using namespace std;  
  
const int MAX=5000+10;  
string Map[MAX];  
int n,m,v,size,s[MAX][2];//s記錄p的位置   
int dir[4][2]={0,1,0,-1,1,0,-1,0};  
bool mark[MAX];  
  
struct Node{  
    int x,y,t;  
    Node(){}  
    Node(int X,int Y,int T):x(X),y(Y),t(T){}  
}start;  
  
void CalculateP(){  
    size=0;  
    for(int i=0;i<n;++i){  
        for(int j=0;j<m;++j){  
            if(Map[i][j] == 'P'){  
                s[size][0]=i;  
                s[size][1]=j;  
                ++size;  
            }else if(Map[i][j] == 'Y'){  
                start=Node(i,j,0);  
            }  
        }  
    }  
}  
  
int BFS(){  
    memset(mark,false,sizeof mark);  
     queue<Node>q;  
     Node oq,next;  
     q.push(start);  
     mark[start.x*m+start.y]=true;  
     while(!q.empty()){  
        oq=q.front();  
        q.pop();  
        for(int i=0;i<4;++i){  
            next=Node(oq.x+dir[i][0],oq.y+dir[i][1],oq.t);;  
            if(next.x<0 || next.y<0 || next.x>=n || next.y>=m)continue;  
            if(mark[next.x*m+next.y] || Map[next.x][next.y] == '#')continue;  
            mark[next.x*m+next.y]=true;  
            if(Map[next.x][next.y] == 'C')return next.t;  
            if(Map[next.x][next.y] == 'P'){  
                int len=q.size();  
                for(int j=0;j<size;++j){  
                    mark[s[j][0]*m+s[j][1]]=true;  
                    q.push(Node(s[j][0],s[j][1],oq.t));  
                }  
                while(len--)next=q.front(),q.pop(),q.push(next);  
            }else{  
                next.t+=v;  
                q.push(next);  
            }  
         }  
    }  
    return -1;  
}  
  
int main(){  
    while(cin>>n>>m>>v){  
        for(int i=0;i<n;++i)cin>>Map[i];  
        CalculateP();  
        int temp=BFS();  
        if(temp<0)cout<<"Damn teoy!"<<endl;  
        else cout<<temp<<endl;  
    }  
    return 0;  
}  

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=5000+10;
string Map[MAX];
int n,m,v,size,s[MAX][2];//s記錄p的位置
int dir[4][2]={0,1,0,-1,1,0,-1,0};
bool mark[MAX];

struct Node{
	int x,y,t;
	Node(){}
	Node(int X,int Y,int T):x(X),y(Y),t(T){}
}start;

void CalculateP(){
	size=0;
	for(int i=0;i<n;++i){
		for(int j=0;j<m;++j){
			if(Map[i][j] == 'P'){
				s[size][0]=i;
				s[size][1]=j;
				++size;
			}else if(Map[i][j] == 'Y'){
				start=Node(i,j,0);
			}
		}
	}
}

int BFS(){
	memset(mark,false,sizeof mark);
	 queue<Node>q;
	 Node oq,next;
	 q.push(start);
	 mark[start.x*m+start.y]=true;
	 while(!q.empty()){
 		oq=q.front();
 		q.pop();
 		for(int i=0;i<4;++i){
		 	next=Node(oq.x+dir[i][0],oq.y+dir[i][1],oq.t);;
		 	if(next.x<0 || next.y<0 || next.x>=n || next.y>=m)continue;
		 	if(mark[next.x*m+next.y] || Map[next.x][next.y] == '#')continue;
		 	mark[next.x*m+next.y]=true;
		 	if(Map[next.x][next.y] == 'C')return next.t;
		 	if(Map[next.x][next.y] == 'P'){
		 		int len=q.size();
	 			for(int j=0;j<size;++j){
			 		mark[s[j][0]*m+s[j][1]]=true;
			 		q.push(Node(s[j][0],s[j][1],oq.t));
			 	}
			 	while(len--)next=q.front(),q.pop(),q.push(next);
	 		}else{
		 		next.t+=v;
		 		q.push(next);
		 	}
		 }
 	}
 	return -1;
}

int main(){
	while(cin>>n>>m>>v){
		for(int i=0;i<n;++i)cin>>Map[i];
		CalculateP();
		int temp=BFS();
		if(temp<0)cout<<"Damn teoy!"<<endl;
		else cout<<temp<<endl;
	}
	return 0;
}


 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved