程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu4433 locker 密碼鎖(枚舉)

hdu4433 locker 密碼鎖(枚舉)

編輯:C++入門知識

locker
Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 883    Accepted Submission(s): 374


Problem Description
A password locker with N digits, each digit can be rotated to 0-9 circularly.
You can rotate 1-3 consecutive digits up or down in one step.
For examples:
567890 -> 567901 (by rotating the last 3 digits up)
000000 -> 000900 (by rotating the 4th digit down)
Given the current state and the secret password, what is the minimum amount of steps you have to rotate the locker in order to get from current state to the secret password?

 

Input
Multiple (less than 50) cases, process to EOF.
For each case, two strings with equal length (≤ 1000) consists of only digits are given, representing the current state and the secret password, respectively.

 

Output
For each case, output one integer, the minimum amount of steps from the current state to the secret password.
 

Sample Input
111111 222222
896521 183995

Sample Output
2
12

Source
2012 Asia Tianjin Regional Contest
 
dp[i][j][k]表示 前i個已經完全匹配,而這時候,第i+1個已經加了j位,第i+2位已經加了k

轉移分為兩步,枚舉加,枚舉減

注意如果第i位加了a,第i+1位加了b,第i+2位加了c,那麼a>=b>=c這個關系不能錯

 

#include<stdio.h>   
#include<string.h>   
#define inf 1000000000;   
int dp[1005][10][10];  
  
int min(int x,int y)  
{  
    return x<y?x:y;  
}  
int main()  
{  
    int i,j,k,l,a,c,b,len;  
    char s1[1005],s2[1005];  
    while(scanf("%s%s",s1,s2)!=EOF)  
    {  
        len=strlen(s1);  
        for(i=0;i<=len;i++)  
            for(j=0;j<10;j++)  
                for(k=0;k<10;k++)  
                    dp[i][j][k]=inf;  
        dp[0][0][0]=0;  
        for(i=0;i<len;i++)  
            for(j=0;j<10;j++)  
                for(k=0;k<10;k++)  
                {  
                    c=(20+s2[i]-s1[i]-j)%10;//向上   
                    for(a=0;a<=c;a++)  
                        for(b=0;b<=a;b++)  
                        {  
                            dp[i+1][(k+a)%10][b]=min(dp[i+1][(k+a)%10][b],dp[i][j][k]+c);//最多需要c步。   
                            //當前狀態的k到了i+1狀態時到了對應的j位置   
                        }  
                    c=(10-c)%10;//向下   
                    for(a=0;a<=c;a++)  
                        for(b=0;b<=a;b++)  
                        {  
                            dp[i+1][(k-a+10)%10][(10-b)%10]=min(dp[i+1][(k-a+10)%10][(10-b)%10],dp[i][j][k]+c);  
                        }  
                }  
                printf("%d\n",dp[len][0][0]);  
  
    }  
    return 0;  

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved