程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> POJ3723Conscription (最大生成樹之Kruskal)

POJ3723Conscription (最大生成樹之Kruskal)

編輯:C++入門知識

Problem Description
Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

 

Input
The first line of input is the number of test case.
The first line of each test case contains three integers, N, M and R.
Then R lines followed, each contains three integers xi, yi and di.
There is a blank line before each test case.


1 ≤ N, M ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

 


Output
For each test case output the answer in a single line.


Sample Input
2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133


Sample Output
71071
54223

#include<stdio.h>  
 #include<iostream> 
  #include<algorithm>  
 #include<string.h> 
  using namespace std; 
 typedef struct nn  {  
    int x,y,d;  }Node;
  int fath[20005],R,N,M;  __int64 sum; 
 Node edg[50005];  
int cmp(Node a,Node b)  {      return a.d>b.d; 
 }  void set_first(int n)  {      for(int i=0;i<=n;i++)      fath[i]=i; 
 }  int find_father(int x)  {      i
f(x!=fath[x])      fath[x]=find_father(fath[x]);    
  return fath[x]; 
 }  void Kruskal()  {      int xx,yy;    
  sort(edg,edg+R,cmp);   
   for(int i=0
;i<R;i++)      {          xx=find_father(edg[i].x);     
     yy=find_father(edg[i].y);       
   if(xx!=yy)          {              sum-=edg[i].d;     
         fath[xx]=yy;       
   }      }  }  int main()  {      int t;      scanf("%d",&t);      
while(t--)      {          scanf("%d%d%d",&N,&M,&R);      
    for(int i=0;i<R;
i++)          {              scanf("%d%d%d",&edg[i].x,&edg[i].y,&edg[i].d);      
         edg[i].y+=N;     
     }          set_first(N+M);   
       sum=(N+M)*10000;      
    Kruskal();       
   printf("%I64d\n",sum);    
  }  }  

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved