程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> 1007. Maximum Subsequence Sum (25)

1007. Maximum Subsequence Sum (25)

編輯:C++入門知識

分析:

(1)求最大連續子序列,最終輸出最大子序列值以及子序列起始和終止元素。如果數組全為負數,則輸出0以及數組的第一個和最後一個元素。

(2)一個特殊情況。如,輸入的是:

        4

       -1 0 0 -1

       那麼我們輸出的應該是: 0 0 0


題目描述:

 


Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

 


參考代碼:

 

#include<iostream>
using namespace std;
int main()
{
	int N;
	int *input;
	int i;
	int begin=0, end=0, sum=0;  //最終所求的子序列的起始位置,終止位置,以及子序列和。
	int tempSum=0, tempBegin=0, tempEnd=0;  //目前正在考察的子序列的起始位置,終止位置,以及子序列的和。
	
	cin>>N;	
	input = new int[N];	
	for(i=0; i<N; i++)
		cin>>input[i];

	end = N-1;  
	for(i=0; i<N; i++)
	{
		if(tempSum >= 0)
		{
			tempSum += input[i];
			tempEnd = i;
		}
		else {
			//如果tempSum<0,那麼tempSum+input[i]<input[i]
			//所以此時我們要開始考察新的子序列
			tempSum = 0; 
			tempSum += input[i];
			tempBegin = i;
			tempEnd = i;
		}

		//if(tempSum > sum) 這樣寫不能AC,應改為如下:
		if(tempSum > sum || (tempSum == 0 && end == N-1))
		{
			sum = tempSum;
			begin = tempBegin;
			end = tempEnd;
		}		
	}
	cout<<sum<<" "<<input[begin]<<" "<<input[end]<<endl;
	return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved