程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU 1052 Tian Ji -- The Horse Racing(貪心)

HDU 1052 Tian Ji -- The Horse Racing(貪心)

編輯:C++入門知識

Tian Ji -- The Horse Racing Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 14907    Accepted Submission(s): 4286     Problem Description Here is a famous story in Chinese history.   "That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."   "Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."   "Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."   "Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."   "It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"       Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...   However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.   In this problem, you are asked to write a program to solve this special case of matching problem.     Input The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.     Output For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.     Sample Input 3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0     Sample Output 200 0 0                          題目大意:題目意思很好懂,田忌賽馬都懂哈,先給你田忌的n匹馬,給你齊王的n匹馬。問你最多能得多少分,勝一場200分負一場-200分,平一場不得分。               解題思路:自己開始貪心的策略是先用田忌的快馬與齊王的快馬相比,>則勝一場,<則用田忌的慢馬與齊王的快馬相比。=的話這裡沒處理好,所以就WA了。看了下大牛的博客。講下思路。   思路是每次先讓慢馬相比,如果>勝一場,<則拉下水,=要看自己的快馬能不能贏,不能贏,則拉下水,能贏則贏一場。 下面文字來源於nyist_xiaod 1.若田忌最慢的馬可以戰勝齊王最慢的馬,那麼就讓它戰勝那匹慢馬,勝利場次加1。(田忌最慢馬 > 齊王最慢馬) 2.若田忌最慢的馬不能戰勝齊王最慢的馬,那麼它更加不能戰勝其他的馬,那就讓它輸,而且輸給齊王最快馬,失敗場次加1。(田忌最慢馬 < 齊王最快馬) 3.若田忌最慢的馬與齊王最慢的馬速度相等。此時,不能簡單地認為與它打成平手就是最好情況,相反,打平是下下策,為什麼呢? 因為自己後面的隊友很有可能戰勝此時對方的這匹慢馬,所以就算自己輸一場,隊友也能幫忙贏回一場,而勝一場,輸一場的收益和打平一場的收益是一樣的,而且自己輸的時候可以拉對方最快的馬下水,給己方最快的馬創造更大的勝利機會(因為它失去了一個強勁的對手),也就是說己方最快的馬很可能因為自己的犧牲再勝利一場,從這個角度看,還是自己故意輸掉比較好。   但是,還有一點需要注意,當自己放水前,如果己方最快的馬原本就比對方最快的馬快,然後還輸給對方最快的馬,那麼己方最快的馬的才華就浪費了,為什麼? 很簡單,它原本就能贏,需要你放水麼?- -!換句話說,這種情況下,自己的犧牲沒有一點價值。 所以,在放水時,一定要保證己方最快馬不快於對方最快馬。滿足此條件後,讓己方最慢馬與對方最快馬去比賽(有可能平局),這樣,田忌的馬就得到了充分的利用。   AC代碼:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;

int a[1005];
int b[1005];
int cmp(int a,int b)
{
    if(a>b) return 1;
    return 0;
}

int main()
{
    int n,i,j,sum,len1,len2;
    while(scanf("%d",&n)&&n)
    {
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        sort(a,a+n,cmp); //田忌的馬從快到慢排序
        for(i=0;i<n;i++)
            scanf("%d",&b[i]);
        sort(b,b+n,cmp); //齊王的馬從快到慢排序
        i=0,j=0;
        len1=len2=n-1;  //最慢的馬的位置
        sum=0;
        while(i<=len1&&j<=len2)
        {
            if(a[len1]>b[len2]) //田忌慢馬>齊王慢馬
            {
                sum++;  //先勝一場
                len1--,len2--;
            }
            else if(a[len1]<b[len2])
            {
                 sum--;    //拿最慢的馬與齊王快馬賽
                 j++;
                 len1--;
            }
            else
            {
                if(i<len1) //除去最快的馬還有別的馬
                {
                    if(a[i]<=b[j])  //田忌的快馬贏不了
                    {
                        if(a[len1]<b[j])
                            sum--;
                        len1--,j++;
                    }
                    else
                    {
                        sum++;  //快馬贏
                        i++; j++;
                    }
                }
                else
                {
                    len1--,len2--; //平局
                }
            }
        }

        printf("%d\n",sum*200);
    }
    return 0;
}

/*
4
70 65 50 20
70 65 55 20
4
70 60 50 20
70 65 55 20
4
70 55 50 20
70 65 55 20
*/

//15MS 236K

 


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved