程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> UVA 111 History Grading(dp + LCS)

UVA 111 History Grading(dp + LCS)

編輯:C++入門知識

Background Many problems in Computer Science involve maximizing some measure according to constraints. Consider a history exam in which students are asked to put several historical events into chronological order. Students who order all the events correctly will receive full credit, but how should partial credit be awarded to students who incorrectly rank one or more of the historical events? Some possibilities for partial credit include: 1 point for each event whose rank matches its correct rank 1 point for each event in the longest (not necessarily contiguous) sequence of events which are in the correct order relative to each other. For example, if four events are correctly ordered 1 2 3 4 then the order 1 3 2 4 would receive a score of 2 using the first method (events 1 and 4 are correctly ranked) and a score of 3 using the second method (event sequences 1 2 4 and 1 3 4 are both in the correct order relative to each other). In this problem you are asked to write a program to score such questions using the second method. The Problem Given the correct chronological order of n events  as  where  denotes the ranking of event i in the correct chronological order and a sequence of student responses  where denotes the chronological rank given by the student to event i; determine the length of the longest (not necessarily contiguous) sequence of events in the student responses that are in the correct chronological order relative to each other. The Input The first line of the input will consist of one integer n indicating the number of events with  . The second line will contain n integers, indicating the correct chronological order of n events. The remaining lines will each consist of n integers with each line representing a student's chronological ordering of the n events. All lines will contain n numbers in the range  , with each number appearing exactly once per line, and with each number separated from other numbers on the same line by one or more spaces. The Output For each student ranking of events your program should print the score for that ranking. There should be one line of output for each student ranking. Sample Input 1 4 4 2 3 1 1 3 2 4 3 2 1 4 2 3 4 1 Sample Output 1 1 2 3 Sample Input 2 10 3 1 2 4 9 5 10 6 8 7 1 2 3 4 5 6 7 8 9 10 4 7 2 3 10 6 9 1 5 8 3 1 2 4 9 5 10 6 8 7 2 10 1 3 8 4 9 5 7 6 Sample Output 2 6 5 10 9 題意:給定一些歷史事件發生的順序, 要求出相同發生的順序。 思路:最長公共子序列問題。要注意題目中輸入的是事件。所以要num1[sb] = i。這樣來存發生順序。 代碼:

#include <stdio.h>
#include <string.h>

int n, num1[25], num2[25], i, j, d[25][25], sb;

int max(int a, int b) {
	return a > b ? a : b;
}
int main() {
	scanf("%d", &n);
	for (i = 1; i <= n; i ++) {
		scanf("%d", &sb);
		num1[sb] = i;
	}
	while (~scanf("%d", &sb)) {
		num2[sb] = 1;
		memset(d, 0, sizeof(d));
		for (i = 2; i <= n; i ++) {
			scanf("%d", &sb);
			num2[sb] = i;
		}
		for (i = 1; i <= n; i ++)
			for (j = 1; j <= n; j ++) {
				if (num1[i] == num2[j])
					d[i][j] = d[i - 1][j - 1] + 1;
				else
					d[i][j] = max(d[i - 1][j], d[i][j - 1]);
			}
		printf("%d\n", d[n][n]);
	}
	return 0;
}

 


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved