程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU1069:Monkey and Banana(DP+貪心)

HDU1069:Monkey and Banana(DP+貪心)

編輯:C++入門知識

Problem Description A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.   The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.    They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.    Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.     Input The input file will contain one or more test cases. The first line of each test case contains an integer n, representing the number of different blocks in the following data set. The maximum value for n is 30. Each of the next n lines contains three integers representing the values xi, yi and zi. Input is terminated by a value of zero (0) for n.     Output For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".     Sample Input 1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0     Sample Output Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342         題意:給出n個長方體的三邊,求疊羅漢能疊的最高高度,要求上面長方體的底面積要小於下面的,每個長方體可以無限取   思路:用大了貪心的思想,由於n只有30,而且三邊位置可以變化,可以將所有情況全部存起來再拍一次序,然後再將所有狀況進行一次循環找出最大值

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

struct node
{
    int x,y,z;
} dp[35*3];

int hei[35*3];

int cmp(node a,node b)
{
    if(a.x!=b.x)
        return a.x<b.x;
    if(a.y!=b.y)
        return a.y<b.y;
    a.z<b.z;
}

int main()
{
    int n,a,b,c,i,j,maxn,ans,cas = 1;
    while(~scanf("%d",&n),n)
    {
        for(i = 0; i<n; i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            dp[i*3+0].x = a>b?a:b;
            dp[i*3+0].y = a>b?b:a;
            dp[i*3+0].z = c;
            dp[i*3+1].x = b>c?b:c;
            dp[i*3+1].y = b>c?c:b;
            dp[i*3+1].z = a;
            dp[i*3+2].x = a>c?a:c;
            dp[i*3+2].y = a>c?c:a;
            dp[i*3+2].z = b;
        }
        sort(dp,dp+3*n,cmp);
        hei[0] = ans = dp[0].z;
        for(i = 1; i<n*3; i++)
        {
            maxn = 0;
            for(j = 0; j<i; j++)
            {
                if(dp[j].x<dp[i].x && dp[j].y<dp[i].y && hei[j]>maxn)
                    maxn = hei[j];
                hei[i] = maxn+dp[i].z;
                if(hei[i]>ans)
                    ans = hei[i];

            }
        }
        printf("Case %d: maximum height = %d\n",cas++,ans);
    }

    return 0;
}

 


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved