程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> POJ 2352 Stars

POJ 2352 Stars

編輯:C++入門知識

2013-09-05 16:09 70人閱讀 評論(0) 收藏 舉報 Stars Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 27342 Accepted: 11961 Description Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.     For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.   You are to write a program that will count the amounts of the stars of each level on a given map. Input The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. Output The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1. Sample Input 5 1 1 5 1 7 1 3 3 5 5 Sample Output 1 2 1 1 0 Hint This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. Source Ural Collegiate Programming Contest 1999     一開始老想著用multiset, 想了一會沒有想到,突然想到可以用線段樹,一次ac

#include <iostream>  
#include <cstdio>  
#include <cstring>  
#include <cmath>  
#define N 33000  
#define M 16000  
using namespace std;  
struct num  
{  
    int l,r,sum;  
}a[4*N];  
struct inf  
{  
    int x,y;  
}b[M];  
int level[M],res;  
int main()  
{  
    //freopen("data.in","r",stdin);  
    void pre_build(int k,int l,int r);  
    void find(int k,int l,int r);  
    void update(int k,int l);  
    int n,Max;  
    while(scanf("%d",&n)!=EOF)  
    {  
        Max=0;  
        for(int i=1;i<=n;i++)  
        {  
            scanf("%d %d",&b[i].x,&b[i].y);  
            b[i].x+=1;  
            Max=max(Max,b[i].x);  
        }  
        pre_build(1,1,Max);  
        memset(level,0,sizeof(level));  
        for(int i=1;i<=n;i++)  
        {  
            int x =b[i].x;  
            int y =b[i].y;  
            res=0;  
            find(1,1,x);  
            level[res]++;  
            update(1,x);  
        }  
        for(int i=0;i<=n-1;i++)  
        {  
            printf("%d\n",level[i]);  
        }  
    }  
    return 0;  
}  
void pushup(int k)  
{  
    a[k].sum=a[k<<1].sum+a[k<<1|1].sum;  
}  
void pre_build(int k,int l,int r)  
{  
    a[k].l = l;  
    a[k].r = r;  
    if(l==r)  
    {  
        a[k].sum=0;  
        return ;  
    }  
    int mid=(l+r)>>1;  
    pre_build(k<<1,l,mid);  
    pre_build(k<<1|1,mid+1,r);  
    pushup(k);  
}  
void find(int k,int l,int r)  
{  
    if(a[k].l==l&&a[k].r==r)  
    {  
        res+=a[k].sum;  
        return ;  
    }  
    int mid=(a[k].l+a[k].r)>>1;  
    if(r<=mid)  
    {  
        find(k<<1,l,r);  
    }else if(l>mid)  
    {  
        find(k<<1|1,l,r);  
    }else  
    {  
        find(k<<1,l,mid);  
        find(k<<1|1,mid+1,r);  
    }  
}  
void update(int k,int l)  
{  
    if(a[k].l==a[k].r)  
    {  
        a[k].sum+=1;  
        return ;  
    }  
    int mid=(a[k].l+a[k].r)>>1;  
    if(l<=mid)  
    {  
        update(k<<1,l);  
    }else  
    {  
        update(k<<1|1,l);  
    }  
    pushup(k);  
}  

 


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved