程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu 1069 Monkey and Banana (兩種解法 1.dp 2.記憶化搜索)

hdu 1069 Monkey and Banana (兩種解法 1.dp 2.記憶化搜索)

編輯:C++入門知識

Monkey and Banana Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6069    Accepted Submission(s): 3085     Problem Description A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.   The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.    They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.   Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.     Input The input file will contain one or more test cases. The first line of each test case contains an integer n, representing the number of different blocks in the following data set. The maximum value for n is 30. Each of the next n lines contains three integers representing the values xi, yi and zi. Input is terminated by a value of zero (0) for n.     Output For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".     Sample Input 1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0     Sample Output Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342     Source University of Ulm Local Contest 1996     思路1:dp 一個長方體有三種放法,x、y、z (x<=y)。 按照x從大到小,y從大到小排序後,有方程: dp[i]=dp[j]+q[j].z   代碼:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define maxn 105
#define INF 0x3f3f3f3f
using namespace std;

int n,m,ans,cnt;
int dp[maxn];
struct Node
{
    int x,y,z;
}q[maxn];

bool cmp(Node xx,Node yy)
{
    if(xx.x!=yy.x) return xx.x>yy.x;
    return xx.y>yy.y;
}
void solve()
{
    int i,j;
    memset(dp,0,sizeof(dp));
    for(i=1;i<=cnt;i++)
    {
        for(j=0;j<i;j++)
        {
            if(q[i].x<q[j].x&&q[i].y<q[j].y) dp[i]=max(dp[i],dp[j]+q[i].z);
        }
    }
    ans=0;
    for(i=1;i<=cnt;i++)
    {
        ans=max(ans,dp[i]);
    }
}
int main()
{
    int i,j,t,x[3],test=0;
    while(scanf("%d",&n),n)
    {
        cnt=0;
        q[0].x=q[0].y=INF;
        for(i=1;i<=n;i++)
        {
            scanf("%d%d%d",&x[0],&x[1],&x[2]);
            sort(x,x+3);
            q[++cnt].x=x[0],q[cnt].y=x[1],q[cnt].z=x[2];  // 需保證x<=y WA了幾次
            q[++cnt].x=x[1],q[cnt].y=x[2],q[cnt].z=x[0];
            q[++cnt].x=x[0],q[cnt].y=x[2],q[cnt].z=x[1];
        }
        sort(q+1,q+cnt+1,cmp);
        solve();
        printf("Case %d: maximum height = %d\n",++test,ans);
    }
    return 0;
}
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define maxn 105
using namespace std;

int n,m,ans,cnt;
int dp[maxn];
struct Node
{
    int x,y,z;
}q[maxn];

int dfs(int pos)
{
    if(dp[pos]!=-1) return dp[pos];
    int i,j,nx,ny,ma;
    nx=q[pos].x;
    ny=q[pos].y;
    ma=0;
    for(i=1;i<=cnt;i++)
    {
        if(q[i].x<nx&&q[i].y<ny) ma=max(ma,dfs(i));
    }
    dp[pos]=ma+q[pos].z;
    return dp[pos];
}
int main()
{
    int i,j,t,x[3],test=0;
    while(scanf("%d",&n),n)
    {
        cnt=0;
        for(i=1;i<=n;i++)
        {
            scanf("%d%d%d",&x[0],&x[1],&x[2]);
            sort(x,x+3);
            q[++cnt].x=x[0],q[cnt].y=x[1],q[cnt].z=x[2];  // x、y需按順序 WA了好多次
            q[++cnt].x=x[1],q[cnt].y=x[2],q[cnt].z=x[0];
            q[++cnt].x=x[0],q[cnt].y=x[2],q[cnt].z=x[1];
        }
        ans=0;
        memset(dp,-1,sizeof(dp));
        for(i=1;i<=cnt;i++)
        {
            t=dfs(i);
            if(ans<t) ans=t;
        }
        printf("Case %d: maximum height = %d\n",++test,ans);
    }
    return 0;
}

 


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved