程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDOJ 1405 The Last Practice

HDOJ 1405 The Last Practice

編輯:C++入門知識

HDOJ 1405 The Last Practice


Problem Description
Tomorrow is contest day, Are you all ready?
We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final.

Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem.
what does this problem describe?
Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.

Input
Input file contains multiple test case, each case consists of a positive integer n(1< n<65536), one per line. a negative terminates the input, and it should not to be processed.

Output
For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.

Sample Input
60
12
-1

Sample Output
Case 1.
2 2 3 1 5 1

Case 2.
2 2 3 1

Hint
60=2^2*3^1*5^1

它說的是一些素數!不是全部是素數!既然是從小到大,所以從2開始遍歷到根號(n)就可以了。如果最後n還是大於1的,說明n沒除完,還剩余一個n^1.

格式!!!
每行的最後一定有一個空格。
各行之間有一個空行!
Case n.!!!數字後面有一個‘.’點。。。

import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int tm = 0;
        while(sc.hasNext()){
            int n = sc.nextInt();
            if(n<0){
                return ;
            }
            if(tm>0){
                System.out.println();
            }

            System.out.println("Case "+(++tm)+".");
            for(int i=2;i<=Math.sqrt(n);i++){
                int num = 0;
                while(n%i==0){
                    n=n/i;
                    num++;
                }
                if(num!=0){
                    System.out.print(i+" "+num+" ");
                }
            }
            if(n>1){
                System.out.print(n+" 1 ");
            }
            System.out.println();

        }
    }

}
 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved