程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> 關於C++ >> CSU 1354Distinct Subsequences 求不相同子序列的和 dp

CSU 1354Distinct Subsequences 求不相同子序列的和 dp

編輯:關於C++

題目鏈接:點擊打開鏈接


Description

Give a positive number, count the sum of the distinct subsequence of it, moreover, any subsequence should not contain leading zeroes except it is zero.
For example, if the number is 1022, the answer is 1 + 0 + 2 + 10 + 12 + 22 + 102 + 122 + 1022 = 1293.

Input

The first line has an integer T, means there are T test cases.
For each test case, there is only one line with a positive number, the number of the digits of it is in range [1, 105].
The size of the input file will not exceed 5MB.

Output

For each test case, print the desired answer in one line. Because the answer may be very large, you just need to print the remainder of it divided by 1000000007 instead.

Sample Input

3
7
1022
1000000001

Sample Output

7
1293
222222223




思路:

dp[i]表示以數字i結尾的子序列的和,num[i]表示以i結尾的子序列的個數

import java.io.PrintWriter;
import java.util.ArrayList;
import java.util.Arrays;
import java.util.Collections;
import java.util.Comparator;
import java.util.Iterator;
import java.util.LinkedList;
import java.util.PriorityQueue;
import java.util.Scanner;
import java.util.TreeSet;
import java.util.Queue;

public class Main {
	static int mod = 1000000007;
	static int N = 100010;
	long[] dp = new long[10], num = new long[10];
	String s;
	void work() {
		int T = cin.nextInt();
		while(T-- > 0) {
			s = cin.next();
			int len = s.length();
			for(int i = 0; i < 10; i++)dp[i] = num[i] = 0;
			for(int i = 0; i < len; i++)
			{
				int x = s.charAt(i)-'0';
				long sum = 0, n = 0;
				for(int j = 0; j < 10; j++)
				{
					sum += dp[j];
					n += num[j];
				}
				if(x>0)n++;
				dp[x] = sum*10%mod + n*x%mod;
				num[x] = n%mod;
			}
			long ans = 0;
			for(int i = 0; i < 10; i++)
				ans = (ans + dp[i])%mod;
			out.println(ans);
		}
	}	

	Main() {
		cin = new Scanner(System.in);
		out = new PrintWriter(System.out);
	}

	public static void main(String[] args) {
		Main e = new Main();
		e.work();
		out.close();
	}
	public Scanner cin;
	public static PrintWriter out;
	int max(int x, int y) {
		return x > y ? x : y;
	}

	int min(int x, int y) {
		return x < y ? x : y;
	}

	double max(double x, double y) {
		return x > y ? x : y;
	}

	double min(double x, double y) {
		return x < y ? x : y;
	}
	long max(long x, long y) {
		return x > y ? x : y;
	}

	long min(long x, long y) {
		return x < y ? x : y;
	}

	static double eps = 1e-8;

	int abs(int x) {
		return x > 0 ? x : -x;
	}

	double abs(double x) {
		return x > 0 ? x : -x;
	}
	long abs(long x) {
		return x > 0 ? x : -x;
	}

	boolean zero(double x) {
		return abs(x) < eps;
	}
}




  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved