程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> 關於C語言 >> 問題一百二十三:統計子串

問題一百二十三:統計子串

編輯:關於C語言

[plain]  Description 
 
輸入一個字符串str和一個子串s,統計str中子串s的個數。  
 
Input 
 
輸入數據有2行,第一行為str,第二行為s,字符串長度不超過128。 
 
Output 
 
輸出子串的個數 
 
Sample Input 
 
 
sdf$$$sdf$$ 
sdf 
 
Sample Output 
 
 

Description

輸入一個字符串str和一個子串s,統計str中子串s的個數。

Input

輸入數據有2行,第一行為str,第二行為s,字符串長度不超過128。

Output

輸出子串的個數

Sample Input


sdf$$$sdf$$
sdf

Sample Output


2
 


[plain]  #include <stdio.h> 
#include <string.h> 
 
int main() 

        int i; 
        int j; 
        int l; 
        int n; 
        int m; 
        int count; 
        int flag; 
        char a[129]; 
        char b[129]; 
 
        gets(a); 
        gets(b); 
 
        n=strlen(a); 
        m=strlen(b); 
        count=0; 
 
        for(i=0; i<n; i++) 
        {    
            flag=1; 
            j=0; 
            if(a[i]==b[j]) 
            {    
                l=i; 
                for(j=1; j<m; j++) 
                { 
                     if(b[j]!=a[++l]) 
                     { 
                         flag=0; 
                        break; 
                     } 
                } 
 
                if(flag) 
                { 
                   count++; 
                } 
            } 
             
        } 
 
        printf("%d", count); 
 
       return 0; 

#include <stdio.h>
#include <string.h>

int main()
{
        int i;
  int j;
  int l;
  int n;
  int m;
  int count;
  int flag;
  char a[129];
  char b[129];

  gets(a);
  gets(b);

  n=strlen(a);
  m=strlen(b);
        count=0;

  for(i=0; i<n; i++)
  {  
   flag=1;
   j=0;
   if(a[i]==b[j])
   {  
    l=i;
       for(j=1; j<m; j++)
    {
      if(b[j]!=a[++l])
      {
       flag=0;
         break;
      }
    }

    if(flag)
    {
          count++;
    }
   }
   
  }

        printf("%d", count);

    return 0;
}

   \

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved