程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> UVALive 4987---Evacuation Plan(區間DP),evacuationplan

UVALive 4987---Evacuation Plan(區間DP),evacuationplan

編輯:C++入門知識

UVALive 4987---Evacuation Plan(區間DP),evacuationplan


題目鏈接

https://icpcarchive.ecs.baylor.edu/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=2988

 

problem Description

Flatland government is building a new highway that will be used to transport weapons from its main weapon plant to the frontline in order to support the undergoing military operation against its neighbor country Edgeland. Highway is a straight line and there are n construction teams working at some points on it. During last days the threat of a nuclear attack from Edgeland has significantly increased. Therefore the construction office has decided to develop an evacuation plan for the construction teams in case of a nuclear attack. There are m shelters located near the constructed highway. This evacuation plan must assign each team to a shelter that it should use in case of an attack. Each shelter entrance must be securely locked from the inside to prevent any damage to the shelter itself. So, for each shelter there must be some team that goes to this shelter in case of an attack. The office must also supply fuel to each team, so that it can drive to its assigned shelter in case of an attack. The amount of fuel that is needed is proportional to the distance from the team’s location to the assigned shelter. To minimize evacuation costs, the office would like to create a plan that minimizes the total fuel needed. Your task is to help them develop such a plan.

Input

The input file contains several test cases, each of them as described below. The first line of the input file contains n — the number of construction teams (1 ≤ n ≤ 4000). The second line contains n integer numbers - the locations of the teams. Each team’s location is a positive integer not exceeding 109 , all team locations are different. The third line of the input file contains m — the number of shelters (1 ≤ m ≤ n). The fourth line contains m integer numbers — the locations of the shelters. Each shelter’s location is a positive integer not exceeding 109 , all shelter locations are different. The amount of fuel that needs to be supplied to a team at location x that goes to a shelter at location y is equal to |x − y|.

Output

For each test case, the output must follow the description below. The first line of the output file must contain z — the total amount of fuel needed. The second line must contain n integer numbers: for each team output the number of the shelter that it should be assigned to. Shelters are numbered from 1 to m in the order they are listed in the input file.

Sample Input

3

1 2 3

2

2 10

Sample Output

8

1 1 2

題意:輸入n  然後輸入n個施工隊的位置(一維坐標) 然後輸入m 再輸入m個防御點的位置(一維坐標),1<=m<=n<=4000  一維坐標小於1e9  現在讓所有的施工隊進入防御點,且每個防御點必須有施工隊進入,求所有施工隊走的最小距離和,並輸出每個施工隊去的防御點編號;

思路:區間DP,定義dp[i][j]  表示前i個施工隊進入j個防御點的最小距離和,那麼有狀態轉移方程:dp[i][j]=max{dp[i-1][j-1],dp[i-1][j]}+abs(a[i]-b[j]) 注意要先對輸入的施工隊和防御點進行從小到大的排序;

代碼如下:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <set>
using namespace std;
int n,m;
long long dp[4006][4006];
bool vis[4006][4006];

struct Node
{
    long long x;
    int id;
    int t;
    bool operator < (const Node & tt) const
    { return x < tt.x; }
}a[4005],b[4005];

bool cmp(const Node s1,const Node s2)
{
    return s1.id<s2.id;
}

void print(int x,int y)
{
    if(y==1&&x==1){
        a[x].t=b[y].id;
        return ;
    }
    print(x-1,y-1+vis[x][y]);
    a[x].t=b[y].id;
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%lld",&a[i].x);
            a[i].id=i;
        }
        sort(a+1,a+n+1);
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        {
            scanf("%lld",&b[i].x);
            b[i].id=i;
        }
        sort(b+1,b+m+1);

        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m&&j<=i;j++)
            {
                if(j==1)
                {
                    dp[i][j]=dp[i-1][j]+abs(a[i].x-b[j].x);
                    vis[i][j]=true;
                }
                else if(j==i)
                {
                    dp[i][j]=dp[i-1][j-1]+abs(a[i].x-b[j].x);
                    vis[i][j]=false;
                }
                else
                {
                    dp[i][j]=min(dp[i-1][j],dp[i-1][j-1])+abs(a[i].x-b[j].x);
                    vis[i][j]=(dp[i-1][j]>dp[i-1][j-1])?false:true;
                }
            }
        }
        cout<<dp[n][m]<<endl;
        print(n,m);
        sort(a+1,a+n+1,cmp);
        for(int i=1;i<=n;i++)
            printf("%d%c",a[i].t,(i==n)?'\n':' ');
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved