程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu 5037 Frog (貪心)

hdu 5037 Frog (貪心)

編輯:C++入門知識

hdu 5037 Frog (貪心)


Frog

Time Limit: 3000/1500 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 789 Accepted Submission(s): 198


Problem Description Once upon a time, there is a little frog called Matt. One day, he came to a river.

The river could be considered as an axis.Matt is standing on the left bank now (at position 0). He wants to cross the river, reach the right bank (at position M). But Matt could only jump for at most L units, for example from 0 to L.

As the God of Nature, you must save this poor frog.There are N rocks lying in the river initially. The size of the rock is negligible. So it can be indicated by a point in the axis. Matt can jump to or from a rock as well as the bank.

You don't want to make the things that easy. So you will put some new rocks into the river such that Matt could jump over the river in maximal steps.And you don't care the number of rocks you add since you are the God.

Note that Matt is so clever that he always choose the optimal way after you put down all the rocks.
Input The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains N, M, L (0<=N<=2*10^5,1<=M<=10^9, 1<=L<=10^9).

And in the following N lines, each line contains one integer within (0, M) indicating the position of rock.
Output For each test case, just output one line “Case #x: y", where x is the case number (starting from 1) and y is the maximal number of steps Matt should jump.
Sample Input
2
1 10 5
5
2 10 3
3
6

Sample Output
Case #1: 2
Case #2: 4

貪心思想:每次總是盡量讓青蛙走最近的石頭,需要記錄當前和上一個青蛙跳的石頭位置。

1、如果可以跳到下一個石頭能到達,就跳到最遠的那個;

2、否則,就需要添加加石頭,石頭加在max(now+1,pre+l+1)處,也就是pre剛好不能跳到的,now能跳到的最近的那一個。使前一個和後一個距離總為L+1,得到最優解。


#include"stdio.h"
#include"math.h"
#include"string.h"
#include"iostream"
#include"algorithm"
using namespace std;
#define N 200005
const int inf=(int)1e10;
int a[N];
int max(int a,int b)
{
    return a>b?a:b;
}
int main ()
{
    int n,i,cnt=1,T,m,l,ans;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&l);
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
        a[0]=0;
        a[n+1]=m;
        sort(a,a+n+2);
        n+=2;
        int pre,now;
        pre=-inf;
        now=0;
        ans=0;
        i=1;
        while(nownow&&a[i-1]<=now+l)
            {
                pre=now;
                now=a[i-1];
                ans++;
            }
            else
            {
                int w=(a[i]-now)/(l+1)-1;    
                if(w>0)
                {
                    int t=max(now+1,pre+l+1);
                    pre=t+(w-1)*(l+1);
                    now+=w*(l+1);
                    ans+=w*2;
                }
                else
                {
                    int t=max(now+1,pre+l+1);
                    pre=now;
                    now=t;
                    ans++;
                }
            }
        }
        printf("Case #%d: %d\n",cnt++,ans);
    }
    return 0;
}



  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved